Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727022 - [4.2] ClusterOperator machine-config missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator machine-config missing ClusterStatusConditionType Upgra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Erica von Buelow
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 09:35 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 999 0 None closed Bug 1727022: set upgradeable operator condition 2020-01-30 16:28:25 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:18 UTC

Description Liang Xia 2019-07-04 09:35:28 UTC
Description of problem:
Check clusteroperator machine-config, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator machine-config's detail.
oc get co machine-config -o yaml

Actual results:
ClusterOperator machine-config missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co machine-config -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:51:42Z"
  generation: 1
  name: machine-config
  resourceVersion: "13332"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/machine-config
  uid: de9945e8-9d45-11e9-945d-023561f97408
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:52:17Z"
    message: Cluster has deployed 4.2.0-0.nightly-2019-06-30-221852
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T03:52:18Z"
    message: Cluster version is 4.2.0-0.nightly-2019-06-30-221852
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-03T03:51:42Z"
    status: "False"
    type: Degraded
  extension:
    master: all 3 nodes are at latest configuration rendered-master-5cbc352535b9631c274f14b4ec4f2c99
    worker: all 2 nodes are at latest configuration rendered-worker-e9bf5b3eff2737e9d5277d4fc8e7808a
  relatedObjects:
  - group: ""
    name: openshift-machine-config-operator
    resource: namespaces
  - group: machineconfiguration.openshift.io
    name: master
    resource: machineconfigpools
  - group: machineconfiguration.openshift.io
    name: worker
    resource: machineconfigpools
  - group: machineconfiguration.openshift.io
    name: cluster
    resource: controllerconfigs
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 2 Liang Xia 2019-07-29 02:20:59 UTC
The issue has been fixed.

$ oc get co machine-config -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-29T01:53:48Z"
  generation: 1
  name: machine-config
  resourceVersion: "12101"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/machine-config
  uid: b4ee1e6c-b1a3-11e9-bb54-000d3a92e279
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-29T01:55:49Z"
    message: Cluster has deployed 4.2.0-0.nightly-2019-07-28-222114
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-29T01:55:49Z"
    message: Cluster version is 4.2.0-0.nightly-2019-07-28-222114
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-29T01:53:48Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-29T01:55:49Z"
    reason: AsExpected
    status: "True"
    type: Upgradeable
  extension:
    master: all 3 nodes are at latest configuration rendered-master-b5d9373dd835b8b9e020899d0b8c78d2
    worker: all 2 nodes are at latest configuration rendered-worker-e12b51053b0802ff8a4bb259dc243610
  relatedObjects:
  - group: ""
    name: openshift-machine-config-operator
    resource: namespaces
  - group: machineconfiguration.openshift.io
    name: master
    resource: machineconfigpools
  - group: machineconfiguration.openshift.io
    name: worker
    resource: machineconfigpools
  - group: machineconfiguration.openshift.io
    name: cluster
    resource: controllerconfigs
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-07-28-222114

Comment 3 errata-xmlrpc 2019-10-16 06:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.