Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727023 - [4.2] ClusterOperator marketplace missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator marketplace missing ClusterStatusConditionType Upgradeable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Alexander Greene
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks: 1822102
TreeView+ depends on / blocked
 
Reported: 2019-07-04 09:38 UTC by Liang Xia
Modified: 2020-04-08 09:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 215 0 None closed Bug 1727023: [status] Add upgradeable condition 2020-09-10 18:23:59 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:18 UTC

Description Liang Xia 2019-07-04 09:38:16 UTC
Description of problem:
Check clusteroperator marketplace, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator marketplace's detail.
oc get co marketplace -o yaml

Actual results:
ClusterOperator marketplace missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co marketplace -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:55:57Z"
  generation: 1
  name: marketplace
  resourceVersion: "9402"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/marketplace
  uid: 76ae5ba6-9d46-11e9-84e0-06632ee176f0
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:56:17Z"
    message: 'Successfully progressed to release version: 4.2.0-0.nightly-2019-06-30-221852'
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-03T03:56:17Z"
    message: 'Available release version: 4.2.0-0.nightly-2019-06-30-221852'
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T03:55:57Z"
    message: Current CR sync ratio (1) meets the expected success ratio (0.3)
    status: "False"
    type: Degraded
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-marketplace
    resource: namespaces
  - group: operators.coreos.com
    name: ""
    namespace: openshift-marketplace
    resource: OperatorSource
  - group: operators.coreos.com
    name: ""
    namespace: openshift-marketplace
    resource: CatalogSourceConfig
  - group: operators.coreos.com
    name: ""
    namespace: openshift-marketplace
    resource: CatalogSource
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 2 Fan Jia 2019-07-16 10:20:33 UTC
test env:
cv: 4.2.0-0.nightly-2019-07-15-074808
There is the description about the "Upgradeable ClusterStatusConditionType" in 4.2.0-0.nightly-2019-07-15-074808
But the status of "Upgradeable" is always "True" when the status of "Progressing" is "True".
#oc describe clusteroperators marketplace
oc describe clusteroperator marketplace
Name:         marketplace
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-07-16T08:42:39Z
  Generation:          1
  Resource Version:    34042
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/marketplace
  UID:                 ab77ffe5-a7a5-11e9-9c5c-069216166896
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-07-16T09:58:57Z
    Message:               Progressing towards release version: 4.2.0-0.nightly-2019-07-15-074808
    Reason:                OperatorStarting
    Status:                True
    Type:                  Progressing
    Last Transition Time:  2019-07-16T09:58:30Z
    Message:               Determining status
    Reason:                OperatorStarting
    Status:                False
    Type:                  Available
    Last Transition Time:  2019-07-16T08:42:39Z
    Message:               Determining status
    Reason:                OperatorStarting
    Status:                False
    Type:                  Degraded
    Last Transition Time:  2019-07-16T09:40:15Z
    Message:               Marketplace is upgradeable
    Reason:                OperatorStarting
    Status:                True
    Type:                  Upgradeable
  Extension:               <nil>
  Related Objects:
    Group:      
    Name:       openshift-marketplace
    Resource:   namespaces
    Group:      operators.coreos.com
    Name:       
    Namespace:  openshift-marketplace
    Resource:   OperatorSource
    Group:      operators.coreos.com
    Name:       
    Namespace:  openshift-marketplace
    Resource:   CatalogSourceConfig
    Group:      operators.coreos.com
    Name:       
    Namespace:  openshift-marketplace
    Resource:   CatalogSource
  Versions:
    Name:     operator
    Version:  4.2.0-0.nightly-2019-07-15-074808

Comment 3 Alexander Greene 2019-07-16 13:30:02 UTC
Jia, Please ignore that PR message, which has been updated to reflect that the marketplace operator should always report upgradeable.

Comment 4 Fan Jia 2019-07-17 07:16:32 UTC
verified the bug for the "upgradeable" always be "True".

Comment 5 errata-xmlrpc 2019-10-16 06:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.