Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727024 - [4.2] ClusterOperator monitoring missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator monitoring missing ClusterStatusConditionType Upgradeable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Sergiusz Urbaniak
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 09:41 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 415 0 None None None 2019-07-29 14:57:49 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:18 UTC

Description Liang Xia 2019-07-04 09:41:32 UTC
Description of problem:
Check clusteroperator monitoring, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator monitoring's detail.
oc get co monitoring -o yaml

Actual results:
ClusterOperator monitoring missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co monitoring -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:55:44Z"
  generation: 1
  name: monitoring
  resourceVersion: "411698"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/monitoring
  uid: 6eaf6084-9d46-11e9-91f9-02a2294f236c
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T04:00:13Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-03T04:00:13Z"
    message: Successfully rolled out the stack.
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T04:00:13Z"
    status: "False"
    type: Progressing
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: monitoring
  - group: ""
    name: openshift-monitoring
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 6 errata-xmlrpc 2019-10-16 06:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.