Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727042 - [4.2] ClusterOperator operator-lifecycle-manager-packageserver missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator operator-lifecycle-manager-packageserver missing Cluste...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
: 1743786 (view as bug list)
Depends On:
Blocks: 1740044 1743786
TreeView+ depends on / blocked
 
Reported: 2019-07-04 10:02 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1743786 (view as bug list)
Environment:
Last Closed: 2019-10-16 06:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1007 0 'None' closed Bug 1727042: Ensure status monitor always reports upgradeable 2020-09-28 17:14:28 UTC
Github operator-framework operator-lifecycle-manager pull 989 0 'None' closed Bug 1727042: feat(operatorstatus): report packageserver as upgradeable 2020-09-28 17:14:28 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:18 UTC

Description Liang Xia 2019-07-04 10:02:37 UTC
Description of problem:
Check clusteroperator operator-lifecycle-manager-packageserver, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator operator-lifecycle-manager-packageserver's detail.
oc get co operator-lifecycle-manager-packageserver -o yaml

Actual results:
ClusterOperator operator-lifecycle-manager-packageserver missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co operator-lifecycle-manager-packageserver -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:52:38Z"
  generation: 1
  name: operator-lifecycle-manager-packageserver
  resourceVersion: "271313"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/operator-lifecycle-manager-packageserver
  uid: fff3ede1-9d45-11e9-945d-023561f97408
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:52:38Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-03T22:57:23Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T22:57:23Z"
    message: Deployed version 0.10.1
    status: "False"
    type: Progressing
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-operator-lifecycle-manager
    resource: namespaces
  - group: operators.coreos.com
    name: packageserver.v0.10.1
    namespace: openshift-operator-lifecycle-manager
    resource: ClusterServiceVersion
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852
  - name: packageserver.v0.10.1
    version: 0.10.1

Comment 3 Liang Xia 2019-08-13 06:21:31 UTC
Still does not show Upgradeable status.

$ oc get co operator-lifecycle-manager-packageserver -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-08-13T05:58:52Z"
  generation: 1
  name: operator-lifecycle-manager-packageserver
  resourceVersion: "7047"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/operator-lifecycle-manager-packageserver
  uid: 6d2d9c70-bd8f-11e9-979a-000d3a91359c
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-08-13T05:58:52Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-13T06:02:36Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-13T06:02:36Z"
    message: Deployed version 0.11.0
    status: "False"
    type: Progressing
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-operator-lifecycle-manager
    resource: namespaces
  - group: operators.coreos.com
    name: packageserver
    namespace: openshift-operator-lifecycle-manager
    resource: ClusterServiceVersion
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-08-12-204658
  - name: packageserver
    version: 0.11.0

Comment 4 Evan Cordell 2019-08-27 14:27:15 UTC
*** Bug 1743786 has been marked as a duplicate of this bug. ***

Comment 7 Bruno Andrade 2019-08-28 03:05:40 UTC
Upgradeable status was shown as expected on version 4.2.0-0.nightly-2019-08-27-222856.

oc get co operator-lifecycle-manager-packageserver -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-08-28T02:04:06Z"
  generation: 1
  name: operator-lifecycle-manager-packageserver
  resourceVersion: "6701"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/operator-lifecycle-manager-packageserver
  uid: 1d94feb6-c938-11e9-bdaa-02ca4cdf8176
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-08-28T02:04:06Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-28T02:07:01Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-28T02:07:01Z"
    message: Deployed version 0.11.0
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-28T02:04:06Z"
    message: Safe to upgrade
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-operator-lifecycle-manager
    resource: namespaces
  - group: operators.coreos.com
    name: packageserver
    namespace: openshift-operator-lifecycle-manager
    resource: ClusterServiceVersion
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-08-27-222856
  - name: packageserver
    version: 0.11.0

Considering that, marking as VERIFIED

Comment 8 errata-xmlrpc 2019-10-16 06:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.