Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727044 - [4.2] ClusterOperator storage missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator storage missing ClusterStatusConditionType Upgradeable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Fabio Bertinatto
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 10:04 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-storage-operator pull 41 0 None closed Bug 1727044: Set missing Upgradeable condition 2020-03-24 09:08:36 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:18 UTC

Description Liang Xia 2019-07-04 10:04:57 UTC
Description of problem:
Check clusteroperator storage, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator storage's detail.
oc get co storage -o yaml

Actual results:
ClusterOperator storage missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co storage -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:55:39Z"
  generation: 1
  name: storage
  resourceVersion: "7664"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/storage
  uid: 6b9ced04-9d46-11e9-84e0-06632ee176f0
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:55:39Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T03:55:39Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-03T03:55:39Z"
    status: "False"
    type: Progressing
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-cluster-storage-operator
    resource: namespaces
  - group: config.openshift.io
    name: cluster
    resource: infrastructures
  - group: storage.k8s.io
    name: gp2
    resource: storageclasses
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 1 Fabio Bertinatto 2019-07-16 15:11:11 UTC
PR submited: https://github.com/openshift/cluster-storage-operator/pull/41

Comment 3 Liang Xia 2019-07-18 01:43:20 UTC
Move bug to verified as the issue is fixed.

$ oc get co storage -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-18T01:06:12Z"
  generation: 1
  name: storage
  resourceVersion: "8867"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/storage
  uid: 3c1e46ad-a8f8-11e9-8236-000d3a93c3f4
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-18T01:06:12Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-18T01:06:12Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-18T01:06:12Z"
    status: "True"
    type: Upgradeable
  - lastTransitionTime: "2019-07-18T01:06:12Z"
    status: "False"
    type: Progressing
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-cluster-storage-operator
    resource: namespaces
  - group: config.openshift.io
    name: cluster
    resource: infrastructures
  - group: storage.k8s.io
    name: managed-premium
    resource: storageclasses
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-07-18-003042

Comment 4 errata-xmlrpc 2019-10-16 06:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.