Bug 17273 - make modules fails to build pcmcia after kernel (src) upgrade to 2.2.14-12
make modules fails to build pcmcia after kernel (src) upgrade to 2.2.14-12
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-06 01:36 EDT by Geoff Collis
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Collis 2000-09-06 01:36:39 EDT
I installed RedHat 6.1 on a IBP thinkpad 240. To get my 3Com PCMCIA card to work I need to upgrade the kernel to 2.2.14-12. I installed  the 
new rpm's in two groups.... kernel-2.2.14-12.i386, kernel-pcmcia-2.2.14-12 and kernel-utils-2.2.14.i386. I boot the thinkpad from the new kernel, 
and tested the 3Com card and it works. I also want to get the modem, sound and USB working so I install the kernel source so I can rebuild it. I 
then installed kernel-headers-2.2.14-12, kernel-doc-2.2.14-12, kernel-ibcs-2.2.14-12 and kernel-source-2.2.14-12.

I can successfully build a new kernel and boot from it, but whenever I do "make modules" the pcmcia module does not get built ; the directory 
does not even exist after the build, and hence my 3Com PCMCIA network card does not work. I am obviously doing something wrong but what? 
I have tried make Xconfig serveral times, even manually editting the ".config" file, all fails..... I am a Senior UNIX SysAdmin by profession 
(specializing in Solaris and HP-UX) so I am usually very thorough and rigorous, so hopefully its nothing trvial I overlooked. I have 
tried searching various NewGroups and mailing lists but I cannot find anything that appears to be relevent. Suggestions?
Comment 1 Bugzilla owner 2004-09-30 11:38:49 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.