Bug 1727308 - ca.crt is not set properly when creating identity providers in the web console
Summary: ca.crt is not set properly when creating identity providers in the web console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard: 4.1.6
Depends On: 1727282
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-05 13:40 UTC by Samuel Padgett
Modified: 2019-07-23 18:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the ca.crt value for OpenID identity providers was not set properly when created through the web console. The problem has been fixed, and the ca.crt is now correctly set.
Clone Of: 1727282
Environment:
Last Closed: 2019-07-23 18:12:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 1932 None None None 2019-07-08 16:07:18 UTC
Red Hat Product Errata RHBA-2019:1766 None None None 2019-07-23 18:12:19 UTC

Description Samuel Padgett 2019-07-05 13:40:31 UTC
+++ This bug was initially created as a clone of Bug #1727282 +++

Description of problem:
When using the management console to add and OpenID IdentityProvider the secret with the CA is created empty.


Version-Release number of selected component (if applicable):
4.1


How reproducible:
Always


Steps to Reproduce:
1. Add an OpenID provider using the management console with a file uploaded as CA using the form
2. Check the oauth CRD
$ oc get -o yaml oauth cluster | grep "name: openid-ca-"
        name: openid-ca-87tsz
2. Check the configmap
$ oc get configmap -n openshift-config openid-ca-87tsz
NAME              DATA   AGE
openid-ca-87tsz   0      15s


Actual results:
The configmap is empty.


Expected results:
The configmap should contain the content of the uploaded file


Additional info:

Comment 1 Samuel Padgett 2019-07-05 13:49:23 UTC
https://github.com/openshift/console/pull/1932

Comment 3 XiaochuanWang 2019-07-10 09:13:54 UTC
The generated configmap in openshift-config contains correct data content which "ca.crt" as key.

This could be verified.

Tested on 4.1.0-0.nightly-2019-07-09-205457
Console image is quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:46a7288cd0f60435ff7bc057dba99feabe8d524442a202ae7669e89e5ebd44c2

Comment 5 errata-xmlrpc 2019-07-23 18:12:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1766


Note You need to log in before you can comment on or make changes to this bug.