Bug 1727444 - Installing python3-qt5-webengine downgrades many qt5-* packages
Summary: Installing python3-qt5-webengine downgrades many qt5-* packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyqtwebengine
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1727429 (view as bug list)
Depends On:
Blocks: 1727429 1728950
TreeView+ depends on / blocked
 
Reported: 2019-07-06 11:58 UTC by Thomas Drake-Brockman
Modified: 2019-08-25 09:23 UTC (History)
10 users (show)

Fixed In Version: pyqtwebengine-5.12.1-5.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-15 00:56:39 UTC


Attachments (Terms of Use)

Description Thomas Drake-Brockman 2019-07-06 11:58:04 UTC
Description of problem:
Installing python3-qt5-webengine downgrades many qt5-* packages 

Version-Release number of selected component (if applicable):
5.1.3

How reproducible:
Always


Steps to Reproduce:
1. dnf install python3-qt5-webengine

Actual results:
➜ sudo dnf install python3-qt5-webengine
Last metadata expiration check: 0:04:15 ago on Sat 06 Jul 2019 19:46:40 AWST.
Dependencies resolved.
==================================================================================================
 Package                           Architecture   Version                   Repository       Size
==================================================================================================
Installing:
 python3-qt5-webengine             x86_64         5.11.3-6.fc30             fedora          103 k
Installing dependencies:
 python3-pyqt5-sip                 x86_64         4.19.17-1.fc30            updates          89 k
 openal-soft                       x86_64         1.19.1-2.fc30             fedora          509 k
 python-qt5-rpm-macros             noarch         5.11.3-6.fc30             fedora           11 k
 python3-qt5                       x86_64         5.11.3-6.fc30             fedora          1.1 M
 python3-qt5-base                  x86_64         5.11.3-6.fc30             fedora          2.7 M
 qt5-qtconnectivity                x86_64         5.12.1-1.fc30             fedora          497 k
 qt5-qtenginio                     x86_64         1:1.6.2-22.fc30           fedora          171 k
 qt5-qtlocation                    x86_64         5.12.1-1.fc30             fedora          3.0 M
 qt5-qtmultimedia                  x86_64         5.12.1-1.fc30             fedora          787 k
 qt5-qtsensors                     x86_64         5.12.1-1.fc30             fedora          195 k
 qt5-qtserialport                  x86_64         5.12.1-1.fc30             fedora           64 k
 qt5-qtsvg                         x86_64         5.12.1-1.fc30             fedora          171 k
 qt5-qttools-common                noarch         5.12.1-1.fc30             fedora           12 k
 qt5-qttools-libs-designer         x86_64         5.12.1-1.fc30             fedora          2.7 M
 qt5-qttools-libs-help             x86_64         5.12.1-1.fc30             fedora          143 k
 qt5-qtwebchannel                  x86_64         5.12.1-1.fc30             fedora           85 k
 qt5-qtwebengine                   x86_64         5.12.2-2.fc30             fedora           40 M
 qt5-qtwebsockets                  x86_64         5.12.1-1.fc30             fedora           89 k
 re2                               x86_64         20160401-8.fc30           fedora          170 k
Downgrading:
 qgnomeplatform                    x86_64         0.5-8.fc30                fedora          129 k
 qt5-qtbase                        x86_64         5.12.1-2.fc30             fedora          3.3 M
 qt5-qtbase-common                 noarch         5.12.1-2.fc30             fedora           14 k
 qt5-qtbase-gui                    x86_64         5.12.1-2.fc30             fedora          5.7 M
 qt5-qtdeclarative                 x86_64         5.12.1-1.fc30             fedora          3.4 M
 qt5-qtwayland                     x86_64         5.12.1-1.fc30             fedora          813 k
 qt5-qtx11extras                   x86_64         5.12.1-1.fc30             fedora           34 k
 qt5-qtxmlpatterns                 x86_64         5.12.1-2.fc30             fedora          1.0 M

Transaction Summary
==================================================================================================
Install    20 Packages
Downgrade   8 Packages

Expected results:
No downgrades, version 5.12.4 installed

Additional info:

Comment 1 Christian Krause 2019-07-07 09:09:50 UTC
According to the changelog of python-qt5, the webengine sub-packages was removed:

* Thu Mar 21 2019 Rex Dieter <rdieter@fedoraproject.org> - 5.12.1-1
- 5.12.1
- omit webengine (now packaged separately)

I guess the new package is https://src.fedoraproject.org/rpms/pyqtwebengine - but this one was never built for F30:

https://koji.fedoraproject.org/koji/packageinfo?packageID=28563

That means, with the last recent update of python-qt5, python3-qt5-webengine is gone and causes update problems on systems having it installed.


Please can you build pyqtwebengine for F30 as well?

Comment 2 Jan Vlug 2019-07-07 10:37:40 UTC
I guess the following problem upgrading several packages is related:

# dnf update
Last metadata expiration check: 2:03:23 ago on 2019-07-07T10:28:18 CEST.
Dependencies resolved.

 Problem 1: package python3-qt5-webengine-5.11.3-6.fc30.x86_64 requires python3-qt5(x86-64) = 5.11.3-6.fc30, but none of the providers can be installed
  - cannot install both python3-qt5-5.12.2-5.fc30.x86_64 and python3-qt5-5.11.3-6.fc30.x86_64
  - cannot install both python3-qt5-5.11.3-6.fc30.x86_64 and python3-qt5-5.12.2-5.fc30.x86_64
  - cannot install the best update candidate for package python3-qt5-webengine-5.11.3-6.fc30.x86_64
  - cannot install the best update candidate for package python3-qt5-5.11.3-6.fc30.x86_64
 Problem 2: package qutebrowser-1.6.3-1.fc30.noarch requires python3-qt5-webengine, but none of the providers can be installed
  - package python3-qt5-webengine-5.11.3-6.fc30.x86_64 requires python3-qt5(x86-64) = 5.11.3-6.fc30, but none of the providers can be installed
  - package python3-qt5-5.11.3-6.fc30.x86_64 requires python3-qt5-base(x86-64) = 5.11.3-6.fc30, but none of the providers can be installed
  - cannot install both python3-qt5-base-5.12.2-5.fc30.x86_64 and python3-qt5-base-5.11.3-6.fc30.x86_64
  - cannot install both python3-qt5-base-5.11.3-6.fc30.x86_64 and python3-qt5-base-5.12.2-5.fc30.x86_64
  - cannot install the best update candidate for package qutebrowser-1.6.3-1.fc30.noarch
  - cannot install the best update candidate for package python3-qt5-base-5.11.3-6.fc30.x86_64
 Problem 3: problem with installed package python3-qt5-webengine-5.11.3-6.fc30.x86_64
  - package python3-qt5-webengine-5.11.3-6.fc30.x86_64 requires python3-qt5(x86-64) = 5.11.3-6.fc30, but none of the providers can be installed
  - cannot install both python3-qt5-5.12.2-5.fc30.x86_64 and python3-qt5-5.11.3-6.fc30.x86_64
  - cannot install both python3-qt5-5.11.3-6.fc30.x86_64 and python3-qt5-5.12.2-5.fc30.x86_64
  - package python3-qt5-webkit-5.12.2-5.fc30.x86_64 requires python3-qt5(x86-64) = 5.12.2-5.fc30, but none of the providers can be installed
  - cannot install the best update candidate for package python3-qt5-webkit-5.11.3-6.fc30.x86_64
 Problem 4: problem with installed package qutebrowser-1.6.3-1.fc30.noarch
  - package qutebrowser-1.6.3-1.fc30.noarch requires python3-qt5-webengine, but none of the providers can be installed
  - package python3-qt5-webengine-5.11.3-6.fc30.x86_64 requires python3-qt5(x86-64) = 5.11.3-6.fc30, but none of the providers can be installed
  - package python3-qt5-5.11.3-6.fc30.x86_64 requires libQt5Quick.so.5(Qt_5.12.1_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtdeclarative-5.12.4-1.fc30.x86_64 and qt5-qtdeclarative-5.12.1-1.fc30.x86_64
  - cannot install both qt5-qtdeclarative-5.12.1-1.fc30.x86_64 and qt5-qtdeclarative-5.12.4-1.fc30.x86_64
  - cannot install the best update candidate for package qt5-qtdeclarative-5.12.1-1.fc30.x86_64
==============================================================================================================================================================================================================================================================
 Package                                                             Architecture                                            Version                                                           Repository                                                Size
==============================================================================================================================================================================================================================================================
Upgrading:
 libnice                                                             x86_64                                                  0.1.16-5.fc30                                                     updates                                                  174 k
 libnice-gstreamer1                                                  x86_64                                                  0.1.16-5.fc30                                                     updates                                                   19 k
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 python3-qt5                                                         x86_64                                                  5.12.2-5.fc30                                                     updates                                                  1.1 M
 python3-qt5-base                                                    x86_64                                                  5.12.2-5.fc30                                                     updates                                                  2.7 M
 qt5-qtdeclarative                                                   x86_64                                                  5.12.4-1.fc30                                                     updates                                                  3.5 M
Skipping packages with broken dependencies:
 python3-qt5-webkit                                                  x86_64                                                  5.12.2-5.fc30                                                     updates                                                  116 k

Transaction Summary
==============================================================================================================================================================================================================================================================
Upgrade  2 Packages
Skip     4 Packages

Comment 3 Rex Dieter 2019-07-07 14:39:45 UTC
Appears we missed building pyqtwebengine for the prior update (now that webengine support is built separately).  f30 branch for the aforementioned package has been requested, and builds will process  as soon as that's completed.

Comment 4 Rex Dieter 2019-07-08 19:40:34 UTC
Triaging to pyqtwebengine, new builds on the way

Comment 5 Fedora Update System 2019-07-08 19:42:06 UTC
FEDORA-2019-6a3adc4a53 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a3adc4a53

Comment 6 Fedora Update System 2019-07-09 01:22:15 UTC
pyqtwebengine-5.12.1-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a3adc4a53

Comment 7 Timothée Floure 2019-07-11 05:49:16 UTC
Hello! Qutebrowser maintainer here, which package is affected by this change.

Is the python3-qt5-webgine package being replaced by the pyqtwebengine (that's weird naming for a python package!) package? I'm a bit confused since we still have python3-qt5-webengine in rawhide, and no pyqtwebengine package.

Comment 8 Rex Dieter 2019-07-11 13:42:45 UTC
Yes and no. :)

the src.rpm changed from python-qt5 to pyqtwebengine, but the run-time package stays the same for upgrade path: python3-qt5-webengine

Does that answer your question?

Comment 9 Timothée Floure 2019-07-14 15:53:59 UTC
(In reply to Rex Dieter from comment #8)
> Yes and no. :)
> 
> the src.rpm changed from python-qt5 to pyqtwebengine, but the run-time
> package stays the same for upgrade path: python3-qt5-webengine
> 
> Does that answer your question?

Yes, thanks!

Comment 10 Fedora Update System 2019-07-15 00:56:39 UTC
pyqtwebengine-5.12.1-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Christian Krause 2019-08-25 09:23:31 UTC
*** Bug 1727429 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.