Bug 172754 - undefined symbol: __stack_chk_fail_local
undefined symbol: __stack_chk_fail_local
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-08 23:20 EST by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 12:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-11-08 23:20:08 EST
Description of problem:

ImageMagick gives the following error message when it tries to load Image::Magick.

[rodd@localhost tmp]$ perl -e "use Image::Magick;"
Can't load
'/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi/auto/Image/Magick/Magick.so'
for module Image::Magick:
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi/auto/Image/Magick/Magick.so:
undefined symbol: __stack_chk_fail_local at
/usr/lib/perl5/5.8.7/i386-linux-thread-multi/DynaLoader.pm line 230.
 at -e line 1
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.



Version-Release number of selected component (if applicable):

ImageMagick-perl-6.2.5.4-1




How reproducible:

Everytime.


Steps to Reproduce:
0. Make sure ImageMagick-perl is installed (yum install ImageMagick-perl).
1. run `perl -e "use Image::Magick;`
  
Actual results:

Error about undefined symbol.



Expected results:

Image::Magick loads without complaint.
Comment 1 Rodd Clarkson 2005-11-08 23:21:34 EST
I tried recompiling ImageMagick on my system, but this didn't fix it.
Comment 2 Rodd Clarkson 2005-11-12 17:03:52 EST
Tried to rebuild ImageMagick against current rawhide (to see if might fix the
problem) and I get this error (which I think is related):

extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/composite
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/conjure
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/montage
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/animate
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/compare
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/identify
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/mogrify
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/import
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/convert
extracting debug info from /var/tmp/ImageMagick-6.2.5.4-root/usr/bin/display
cpio: ImageMagick-6.2.5/<built-in>: No such file or directory
cpio: ImageMagick-6.2.5/PerlMagick/Magick.c: No such file or directory
20934 blocks
+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
*******************************************************************************
*
* WARNING: 'check-rpaths' detected a broken RPATH and will cause 'rpmbuild'
*          to fail. To ignore these errors, you can set the '$QA_RPATHS'
*          environment variable which is a bitmask allowing the values
*          below. The current value of QA_RPATHS is 0x0000.
*
*    0x0001 ... standard RPATHs (e.g. /usr/lib); such RPATHs are a minor
*               issue but are introducing redundant searchpaths without
*               providing a benefit. They can also cause errors in multilib
*               environments.
*    0x0002 ... invalid RPATHs; these are RPATHs which are neither absolute
*               nor relative filenames and can therefore be a SECURITY risk
*    0x0004 ... insecure RPATHs; these are relative RPATHs which are a
*               SECURITY risk
*    0x0008 ... the special '$ORIGIN' RPATHs are appearing after other
*               RPATHs; this is just a minor issue but usually unwanted
*    0x0010 ... the RPATH is empty; there is no reason for such RPATHs
*               and they cause unneeded work while loading libraries
*    0x0020 ... an RPATH references '..' of an absolute path; this will break
*               the functionality when the path before '..' is a symlink
*
*
* Examples:
* - to ignore standard and empty RPATHs, execute 'rpmbuild' like
*   $ QA_RPATHS=$[ 0x0001|0x0010 ] rpmbuild my-package.src.rpm
* - to check existing files, set $RPM_BUILD_ROOT and execute check-rpaths like
*   $ RPM_BUILD_ROOT=<top-dir> /usr/lib/rpm/check-rpaths
*
* 'check-rpaths' is part of 'fedora-rpmdevtools'.
*
*******************************************************************************
ERROR   0001: file '/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi/aut
o/Image/Magick/Magick.so' contains a standard rpath '/usr/lib' in [/usr/lib:/usr
/X11R6/lib]
ERROR   0001: file '/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi/aut
o/Image/Magick/Magick.so' contains a standard rpath '/usr/X11R6/lib' in [/usr/li
b:/usr/X11R6/lib]
error: Bad exit status from /var/tmp/rpm-tmp.33053 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.33053 (%install)
[rodd@localhost ~]$
Comment 3 Rodd Clarkson 2005-11-15 05:46:47 EST
I need to get ImageMagick working again.

Can anyone advise how I might do this.  Is this problem related to ImageMagick,
or is perl missing something?

I haven't got any older RPMs that I can use (and FC4 RPMs won't install) but I'm
happy to build stuff if that's what it takes.  I'm assuming I can pull something
from CVS, but I don't know what or how.

Here's hoping someone can help.
Comment 4 Matthias Clasen 2005-12-19 12:07:14 EST
The gcc 4.1 mass rebuild seems to have succeeded in rebuilding this...

Note You need to log in before you can comment on or make changes to this bug.