Bug 1727574 - Fedora flatpak for this app on registry.fedoraproject.org
Summary: Fedora flatpak for this app on registry.fedoraproject.org
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1727571 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-07 10:43 UTC by rugk
Modified: 2019-08-30 00:52 UTC (History)
11 users (show)

Fixed In Version: epiphany-master-3020190809140603.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-30 00:52:44 UTC
Type: Bug


Attachments (Terms of Use)
WIP container.yaml (546 bytes, text/plain)
2019-07-14 22:16 UTC, Michael Catanzaro
no flags Details
WIP epiphany.yaml (883 bytes, text/plain)
2019-07-14 22:17 UTC, Michael Catanzaro
no flags Details

Description rugk 2019-07-07 10:43:00 UTC
It would be great if you could provide a flatpak package of this app to https://registry.fedoraproject.org/.

Especially for users of Fedora Silverblue https://silverblue.fedoraproject.org/ this then allows a seamless installation and upgrades without rebooting the system (just restarting the application).

Additionally, flatpaks can of course be installed on any distro, so also non-Fedora users could use it too.

More details:
* https://fedoraproject.org/wiki/Workstation/Flatpaks
* https://fedoraproject.org/wiki/Changes/Graphical_Applications_as_Flatpaks

Comment 1 rugk 2019-07-07 15:51:10 UTC
*** Bug 1727571 has been marked as a duplicate of this bug. ***

Comment 2 Michael Catanzaro 2019-07-07 16:19:44 UTC
I'm willing to do this, but I need a simple TODO. Neither of the links you provided is simple....

Comment 3 rugk 2019-07-07 19:05:37 UTC
This was the only doc I've found, but notice I am also still only a user. I've directed your question to the Fedora discussions, however, so maybe someone comes up with some "getting started" guide or so…

https://discussion.fedoraproject.org/t/todo-guide-tutorial-doc-on-how-to-create-a-flatpak-as-a-package-maintainer-from-an-rpm/2039?u=rugk

Comment 4 Tomas Popela 2019-07-08 04:59:55 UTC
(In reply to Michael Catanzaro from comment #2)
> I'm willing to do this, but I need a simple TODO. Neither of the links you
> provided is simple....

Michael, there is https://docs.fedoraproject.org/en-US/flatpak/tutorial/ from Owen.

I actually made an Epiphany RPM Flatpak few months ago, but if I remember correctly the certifications handling was completely broken there, so I was not able to load nearly anything.

Also Epiphany is installed by default in the base image (as in Fedora Workstation), it just doesn't have the launcher installed - you can start it by running 'epiphany' from terminal.

Comment 5 Michael Catanzaro 2019-07-08 14:31:44 UTC
Er yeah, so Epiphany is part of the ostree image? Well that's quite special then. If we create a flatpak version of Epiphany, it would be a little redundant with the system Epiphany. I think that's actually OK though, just something to be aware of.

I kinda think we should remove Epiphany from the ostree image. It's only there for gnome-software to support web apps, but that's not a very compelling feature of gnome-software and we should probably just disable it. At least if we want to keep Epiphany on the ostree image, someone should test that installing web apps from gnome-software on Silverblue actually works.

Another benefit of having a Fedora flatpak is that it could be advertised to users of other distros. I've wanted a stable flatpak of Epiphany for a long time, but I don't want to use flathub because the upstream GNOME runtime is still not in good security shape. A Fedora runtime wouldn't have this problem.

(In reply to Tomas Popela from comment #4) 
> I actually made an Epiphany RPM Flatpak few months ago, but if I remember
> correctly the certifications handling was completely broken there, so I was
> not able to load nearly anything.

Probably an issue with ca-certificates inside the runtime.

Comment 6 Michael Catanzaro 2019-07-14 22:15:56 UTC
I got this far:

$ flatpak-module local-build --install

Results in:

ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M bfcdc6cda9044c819270ff08d960e619 -D /var/lib/mock/module-epiphany-master-3020190714215510-ThreadPoolExecutor-0_1/root -a --capability=cap_ipc_lock --bind=/tmp/mock-resolv.v11wtr7f:/etc/resolv.conf --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/builddir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=en_US.UTF-8 -u mockbuild bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps /builddir/build/SPECS/libhandy.spec

Comment 7 Michael Catanzaro 2019-07-14 22:16:44 UTC
Created attachment 1590584 [details]
WIP container.yaml

Comment 8 Michael Catanzaro 2019-07-14 22:17:13 UTC
Created attachment 1590585 [details]
WIP epiphany.yaml

Comment 9 Michael Catanzaro 2019-07-22 15:46:21 UTC
I tried again. Now libhandy build fails because it tries to install its glade catalog outside the build prefix. I'll try to fix it.

Comment 10 Michael Catanzaro 2019-08-08 14:32:18 UTC
OK, now after 10 days of waiting for my first attempt at a libhandy update, then 10 days of waiting for the next one, I have finally succeeded at building an Epiphany flatpak using the Fedora runtime.

Unfortunately, ca-certificates are broken in the runtime so HTTPS pages cannot be loaded. That would need to be fixed.

There is also some fontconfig bug:

$ flatpak run org.gnome.Epiphany
Fontconfig error: "/etc/fonts/conf.d/50-flatpak.conf", line 4: XML or text declaration not at start of entity

** (epiphany:2): WARNING **: 09:28:49.208: Error retrieving filter https://easylist.to/easylist/easylist.txt: Unacceptable TLS certificate


** (epiphany:2): WARNING **: 09:28:49.211: Error retrieving filter https://easylist.to/easylist/easyprivacy.txt: Unacceptable TLS certificate

Fontconfig error: "/etc/fonts/conf.d/50-flatpak.conf", line 4: XML or text declaration not at start of entity

Comment 11 Michael Catanzaro 2019-08-08 20:10:59 UTC
(In reply to Michael Catanzaro from comment #10)
> Unfortunately, ca-certificates are broken in the runtime so HTTPS pages
> cannot be loaded. That would need to be fixed.
> 
> There is also some fontconfig bug:

Owen has fixed both problems!

Comment 12 Michael Catanzaro 2019-08-08 20:17:04 UTC
Now waiting for the repo to be created. Looks like these get processed pretty quickly.

Comment 13 Fedora Update System 2019-08-09 15:00:16 UTC
FEDORA-FLATPAK-2019-b659c0339d has been submitted as an update to Fedora 30 Flatpaks. https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2019-b659c0339d

Comment 14 Michael Catanzaro 2019-08-09 15:01:26 UTC
Note: I don't really recommend using this flatpak yet because Fedora flatpaks don't currently support debuginfo, so you won't be able to report crashes. But it seems to work OK.

Comment 15 Fedora Update System 2019-08-11 01:17:21 UTC
epiphany-master-3020190809140603.1 has been pushed to the Fedora 30 Flatpaks testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2019-b659c0339d

Comment 16 Ben Cotton 2019-08-13 16:48:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 17 Fedora Update System 2019-08-30 00:52:44 UTC
epiphany-master-3020190809140603.1 has been pushed to the Fedora 30 Flatpaks stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.