Bug 172765 - mcrypt support implementation
mcrypt support implementation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 06:12 EST by Patrick Monnerat
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 04:57:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the RPM spec file to introduce conditional compilation of "php-mcrypt" (2.72 KB, patch)
2005-11-09 06:14 EST, Patrick Monnerat
no flags Details | Diff

  None (edit)
Description Patrick Monnerat 2005-11-09 06:12:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The core packages do not offer the mcrypt support.

OK. I know the reason: it uses the libmcrypt package that resides in the extras repository; enabling mcrypt support would introduce a cross-repository dependency problem.

I think libmcrypt should be part of FC5: PHP may then use it directly from a binary RPM.

My actual problem is that I have to download the update source RPM, modify the spec file and recompile it each time an update is available for PHP.

A workaround to the FC4 dependency problem would be to have conditional "php-mcrypt" package creation in the spec file; this will allow people like me to recompile php more easily with "rpmbuild -D '_with_mcrypt 1' ...", without having to modify the spec file for mcrypt.

Note: people maintaining phprpms on sourceforge do not react to FC4 updates...

I include a patch to the RPM spec file (of version 5.0.4-10.5) to introduce such a conditional compilation. It would be fine if the next php source update may contain such a feature.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Call an mcrypt procedure from PHP

Actual Results:  procedure not present

Expected Results:  Correct execution of procedure

Additional info:
Comment 1 Patrick Monnerat 2005-11-09 06:14:16 EST
Created attachment 120838 [details]
Patch to the RPM spec file to introduce conditional compilation of "php-mcrypt"
Comment 2 Joe Orton 2005-11-23 04:57:50 EST
I'm probably going to remove all these conditional compilation things for FC5,
they are more hassle to maintain than they are worth.  There is nothing stopping
anybody from maintaining a php-mcrypt package in Extras too.

Note You need to log in before you can comment on or make changes to this bug.