Bug 172772 - Avahi package enhancements and minor fixes
Summary: Avahi package enhancements and minor fixes
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks: 171491
TreeView+ depends on / blocked
 
Reported: 2005-11-09 15:11 UTC by Matthias Saou
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 13:55:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (6.31 KB, patch)
2005-11-09 15:12 UTC, Matthias Saou
no flags Details | Diff
Spec file patch, revisited (6.34 KB, patch)
2005-11-18 13:23 UTC, Matthias Saou
no flags Details | Diff

Description Matthias Saou 2005-11-09 15:11:42 UTC
This is against avahi 0.5.2-6.

Attached patch changes :
- Uppercase first letter of the summaries
- Consistency between tabs and spaces
- Adds missing libglade2-devel build requirement
- Glib & Qt3 package dependencies
- Shell test syntax in the scriplets
- Missing ldconfig calls
- Symlinks .so into devel packages
- Pkgconfig Glib & Qt3 files in sub-packages
- Defattr consistency

It's all pretty straightforward.

Comment 1 Matthias Saou 2005-11-09 15:12:29 UTC
Created attachment 120842 [details]
Spec file patch

Comment 2 Jason Vas Dias 2005-11-14 21:49:50 UTC
Thanks for the patch - this bug is now fixed with avahi-*-0.5.2-7 .

Comment 3 Matthias Saou 2005-11-18 13:22:40 UTC
Some parts in 0.5.2-7 are still not fixed. For instance, the qt3 sub-package
(not the qt3-devel one) requires the main "devel" and "qt-devel", which should
be moved to the qt3-devel sub-package. Pkgconfig files should be moved to their
respective devel sub-packages too.

The rest is cosmetic to keep consistent across the spec file : Spaces vs. tabs,
removed quotes in integer test checks etc.

Oh, I also simplified the %defattr/%attr parts, since directories were being
defaulted to 0644(!?) and all of the forced attributes on regular files should
be useless, or considered an upstream bug otherise since it would be "make
install"'s fault.

Matthias

Comment 4 Matthias Saou 2005-11-18 13:23:33 UTC
Created attachment 121223 [details]
Spec file patch, revisited

Comment 5 Matthias Saou 2005-12-20 17:12:56 UTC
Seems like the avahi package still gets quite a lot of attention in
development... do you want me to check all of these issues for the latest package?

Comment 6 Warren Togami 2006-01-24 04:54:32 UTC
Please rediff against latest development, and CC me on all now and future bugs
where you have spec fixes.


Comment 7 Matthias Saou 2007-02-05 13:55:37 UTC
Closing as DEFERRED since all of the problems I had reported, if any are left,
should get caught by the Core+Extras merge review process.


Note You need to log in before you can comment on or make changes to this bug.