Bug 172811 - printconf-tui can't set the default printer when using a remote server
printconf-tui can't set the default printer when using a remote server
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-printer (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 18:10 EST by Steve Cleveland
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 06:36:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Cleveland 2005-11-09 18:10:07 EST
Description of problem:

When using a central cups server and modifying /etc/cups/client.conf and setting
ServerName to a remote server, the printconf-tui tools is unable to set the
default printer.

I realize using a remote cups server, there isn't much to be configured with
system-config-printer, but I would like to be able to set the default printer
from the command line.

Version-Release number of selected component (if applicable):

system-config-printer-0.6.116.4-1


How reproducible:

every time


Steps to Reproduce:
1. Setup a cups server to be accessible remotely
2. edit /etc/cups/client.conf and set ServerName to the cups server
3. restart cups
4. lpstat -v should show all of the printers
5. Run 'printconf-tui --Xdefault --queue=printer'

  
Actual results:

No error message, but lpstat -d still shows the original default printer.


Expected results:

The default printer should change


Additional info:

Using printconf-gui, the printers show up in "browsed queues".  From there I am
able to set the default printer.  This change is reflected in lpstat -d.
Comment 1 Tim Waugh 2006-12-15 06:36:14 EST
You need to run '/usr/sbin/printconf-backend' (or reboot) after the
printconf-tui command.  The printconf-tui command updates the XML configuration;
printconf-backend updates the CUPS configuration from the XML configuration.

Setting to NEXTRELEASE, because the next major release of Red Hat Enterprise
Linux makes this sort of thing much simpler.

Note You need to log in before you can comment on or make changes to this bug.