Bug 172820 - setup - "unknown" file system hfsplus
setup - "unknown" file system hfsplus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-11-09 20:30 EST by Michal Jaegermann
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 14:08:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-11-09 20:30:52 EST
Description of problem:

I happen to have here a CD written in a default format on a Mac OSX machine.
Dropping it into a drive does not result, contrary to expectations, in
an automatic mount.  A bit of digging in a mount manpage how an 'auto' file
type really works (not 'autofs'!!) reveals that mount tries filesystems listed
in '/etc/filesystems' and a content of this file currently looks like this:

ext3
ext2
nodev proc
nodev devpts
iso9660
vfat
hfs

The required filesystem happens to be 'hfsplus' and adding it at the bottom
of this list does result in an automatic mount on an insertion of CD and
after that 'hfsplus' shows up, not that surprisingly, in an output of
'cat /proc/filesystems' too.  Currently this does not mean that nautilus is
noticing a new mount but this looks like an unrelated breakage.

I would suggest that 'hfsplus' should be in '/etc/filesystems' list from
the very beginning (especially that 'man mount' fails to mention it, see
bug #172817).

BTW - 'man mount' claims that '/etc/filesystems' entries marked 'nodev' are
ignored so why they are there is not clear.  Something else looks at this file?

Version-Release number of selected component (if applicable):
setup-2.5.47-1.1
but this actually applies equally well to FC3 and FC4.
Comment 1 Phil Knirsch 2006-01-24 14:08:45 EST
Added in CVS, will be in next build.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.