Bug 1728251 - Cannot scan wireless networks with wpa_supplicant 2.8 (Broadcom)
Summary: Cannot scan wireless networks with wpa_supplicant 2.8 (Broadcom)
Keywords:
Status: CLOSED DUPLICATE of bug 1703745
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Davide Caratti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-09 12:37 UTC by Ben Boeckel
Modified: 2019-07-10 13:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 13:08:47 UTC


Attachments (Terms of Use)

Description Ben Boeckel 2019-07-09 12:37:41 UTC
Description of problem:
Scanning fails 100% of the time with 2.8. Downgrading to wpa_supplicant-2.7-1.fc29.x86_64 makes things work again.

Version-Release number of selected component (if applicable):
1:2.8-2.fc30

The system log has a long line of these messages:

wpa_supplicant[919]: wlp2s0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1

Hardware description from the kernel:

kernel: eth0: Broadcom BCM43b1 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)

Installed driver:

kmod-wl-5.1.16-200.fc29.x86_64-6.30.223.271-26.fc29.x86_64

Also did not work with the 2.8 package (have not rebooted to test the F30 kernel with the downgraded wpa_supplicant):

kmod-wl-5.1.16-300.fc30.x86_64-6.30.223.271-26.fc30.x86_64

I am only using wpa_supplicant and systemd-networkd (no NetworkManager or other management daemon).

Comment 1 Davide Caratti 2019-07-09 22:14:36 UTC
(In reply to Ben Boeckel from comment #0)
> Description of problem:
> Scanning fails 100% of the time with 2.8. Downgrading to
> wpa_supplicant-2.7-1.fc29.x86_64 makes things work again.
> 
> Version-Release number of selected component (if applicable):
> 1:2.8-2.fc30
> 
> The system log has a long line of these messages:
> 
> wpa_supplicant[919]: wlp2s0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
> 
> Hardware description from the kernel:
> 
> kernel: eth0: Broadcom BCM43b1 802.11 Hybrid Wireless Controller
> 6.30.223.271 (r587334)
> 
> Installed driver:
> 
> kmod-wl-5.1.16-200.fc29.x86_64-6.30.223.271-26.fc29.x86_64
> 
> Also did not work with the 2.8 package (have not rebooted to test the F30
> kernel with the downgraded wpa_supplicant):
> 
> kmod-wl-5.1.16-300.fc30.x86_64-6.30.223.271-26.fc30.x86_64
> 
> I am only using wpa_supplicant and systemd-networkd (no NetworkManager or
> other management daemon).

hello,

I think you might have encountered the same issue seen with bz1703745. 
Ideally, we should patch the Broadcom driver to avoid problems when the mesh EID is
present; but unfortunately this is very hard to do without the driver full sources.
(and as discussed in [1], it's a bad idea to leave a feature disabled because it does
not interoperate well with closed-source drivers). There are two alternative
workarounds:

1) avoiding MAC address randomization (https://bugzilla.redhat.com/show_bug.cgi?id=1703745#c63)
2) install a build that does not have CONFIG_MESH (https://bugzilla.redhat.com/show_bug.cgi?id=1703745#c40)
 (a restart of wpa_supplicant.service is then needed)

please let me know if this helps. Thanks!
-- 
davide

[1] https://fedoraproject.org/wiki/Common_F30_bugs#Broadcom_wireless_adapters_using_proprietary_broadcom-wl_driver_do_not_work_reliably

Comment 2 Ben Boeckel 2019-07-10 13:08:47 UTC
It does look like a duplicate of the other one. Thanks for the info. I think I'll finally just replace the wireless chip in this machine with an Intel chipset (been putting it off for a while because it worked well enough).

*** This bug has been marked as a duplicate of bug 1703745 ***


Note You need to log in before you can comment on or make changes to this bug.