Bug 172826 - Feature: selectable dump filtering
Feature: selectable dump filtering
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira Imamura
: FutureFeature, Reopened
Depends On:
Blocks: 176344 215617
  Show dependency treegraph
Reported: 2005-11-09 21:47 EST by Tim Burke
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version: RHEA-2007-0233
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-01 18:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Burke 2005-11-09 21:47:34 EST
In a recent customer meeting the following feature request came up.  I'll do my
best to represent it here.....

The customer is highly interested in diskdump in general.  However, they had
reservations about providing us full dumps for post-mortem diagnosis.  Possible
reasons include:
- bandwidth, upload time, and disk space on our end
- preserve company confidential info in memory?

Consequently, they would like the ability to provide a limited partial crash
dump initially.  Presumably that would provide enough info to diagnose most
issues. However, they recognize that in some cases, a more complete dump may be

One approach to doing this would be to initially configure their systems for
partial crash dumps. Then in the event that a more complete dump is required,
they'd have to attempt to reproduce the issue again.  This is what would have to
be done using the capabilities as of U2.

What they would prefer to be able to do is to configure their systems for full
dumps.  Then they would like a utility that could be run after the system has
been rebooted, to take input from the full dump, and output a separate dump file
which is a partial dump.  Basically, filtering of a dump file.  That way, they
can initially send in to support the minimal dump file size, then if its
warranted, they can later provide the full dump.. without having to try to
reproduce the same problem again.
Comment 1 Akira Imamura 2006-02-24 11:14:41 EST
I need to know further more requirement of the customer so as to compose
this feature. The information I can currently see is not quite enough to
compose it. Please provide me anything you know such as specification. Note
that even if the specification is shown in private comments, I cannot see

Comment 4 Akira Imamura 2006-04-04 09:22:15 EDT
This BZ is just a new feature, so I change severity to "enhancement".
Comment 5 Bob Johnson 2006-04-11 12:19:37 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 6 Akira Imamura 2006-05-11 16:02:23 EDT
I've been working on this feature since this BZ was opened. But
there was not enough time to work on it because I had a lot of
other patches to do. I need to keep working on it. This feature
should be included in U5.

Comment 7 Dave Anderson 2006-05-11 16:55:36 EDT

This kind of feature is essentially what NEC is doing for
the RHEL5 kdump filtering (partial dump) feature.  The difference
from what's being requested here would be:

(1) the NEC utility will start with a full /proc/vmcore while
    running in the kdump kernel environment, and from that file it
    creates a filtered/partial vmcore.
(2) if the original vmcore on the customer system was a compressed
    diskdump already, i.e., instead of an ELF vmcore, then NEC's utility
    would not work -- because NEC is translating from an ELF vmcore to a 
    filtered dumpfile only.

(3) the original kdump ELF vmcore is history as soon as the kdump kernel
    reboots, so both files would have to be saved somewhere.  

So (3) might be considered as a kdump option, i.e., allowing for saving
both the full and partial dump files while running in the kdump environment.
I've added Don's name to the cc: list as a reminder that this might be
a useful kdump option.

Comment 8 Akira Imamura 2006-05-12 14:24:45 EDT
I closed this BZ by mistake. So, I reopen it.
Comment 13 Akira Imamura 2006-12-14 18:32:52 EST
I worked on this feature, and uploaded the latest diskdumputils SRPM which
includes it onto http://people.redhat.com/aimamura/. The SRPM is a beta. So
please use it for test only.
dumpfilter command works correctly on the system that the following kernel
is installed.

Comment 14 Akira Imamura 2006-12-15 17:48:48 EST
I've changed the component to diskcheck by mistake. So I correct it.

Comment 15 Dave Anderson 2007-01-08 15:10:02 EST
Upstream diskdumputils version 1.3.25 containing the feature
has been checked into RHEL-4 CVS, version 1.3.25-1:

Comment 19 Red Hat Bugzilla 2007-05-01 18:59:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.