Bug 172828 - Error indication for return value of futex(2) syscall
Error indication for return value of futex(2) syscall
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: man-pages (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 22:16 EST by Ryan
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 03:44:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan 2005-11-09 22:16:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; Maxthon; .NET CLR 1.1.4322)

Description of problem:
Refer to the futex(2) manual page, when FUTEX_WAIT is specified as futex operation and the futex address doesn't contain the specified value, EWOULDBLOCK would be "returned". But in the actual case, when defined and called through the _syscallN mechanism, -1 is returned while errno is set to EWOULDBLOCK / EAGAIN. I consider as a misleading by the manpage.

Version-Release number of selected component (if applicable):
man-pages-1.67-7

How reproducible:
Couldn't Reproduce


Additional info:
Comment 3 Ivana Varekova 2006-03-21 03:44:42 EST
The man page describes one version of futex function, there is no default futex
function - glibc does not export it (futex function is only used internally).
Comment 4 Michael Kerrisk 2007-05-26 02:28:20 EDT
I've reworked the text in the upstream man page to fix this problem.  The pages
should say "fails with the error", rather than "returns".

Note You need to log in before you can comment on or make changes to this bug.