Bug 172834 - anaconda unable to run with --method hd://foo/bar
anaconda unable to run with --method hd://foo/bar
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 06:19 EST by Ingvar Hagelund
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 23:22:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2005-11-10 06:19:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
While hacking around in the stage2 image, searching for a way to do a harddrive install from another system, I probably found a bug in anaconda. Explicitly, what I really try to do, is to install RHEL into a directory, like Debian's debootstrap. This may or may not be supported by RedHat, but the code lays there, and looks like it's more or less ready to be used.

When I run anaconda with --method hd://hda1/RedHat , it just spits a python traceback at me. I think this is the correct way of saying "Install from /dev/hda1, directory /RedHat".

# anaconda --text --noselinux --method hd://hda1/RedHat  
Probing for video card:   ATI Radeon 7000
Probing for monitor type:   Unknown monitor
Probing for mouse type:   No - mouse
Graphical installation not available...  Starting text mode.
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1040, in ?
    i = string.index(tmpmethod, ":")
  File "/usr/lib64/python2.3/string.py", line 145, in index
    return s.index(*args)
ValueError: substring not found



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run the comand # anaconda --text --noselinux --method hd://hda1/RedHat  


  

Actual Results:  python spits traceback

Expected Results:  The installer should continue, trying to install from /dev/hda1

Additional info:
Comment 1 Jeremy Katz 2005-11-11 23:22:08 EST
That's not the correct syntax for hard drive -- you want something more like
 --method hd:hda:/RedHat

Note You need to log in before you can comment on or make changes to this bug.