Bug 1728349 - Kube Proxy needed to be deployed for ACI to run as a part of upgrade from 3.9 to 3.10
Summary: Kube Proxy needed to be deployed for ACI to run as a part of upgrade from 3.9...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 3.10.z
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-09 18:31 UTC by Mike Cohen
Modified: 2019-08-21 13:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Kube Proxy needs to be deployed for ACI to run as a part of an upgrade from OCP 3.9 to 3.10
Clone Of:
Environment:
Last Closed: 2019-08-21 13:52:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2509 None None None 2019-08-21 13:52:09 UTC

Description Mike Cohen 2019-07-09 18:31:14 UTC
Description of problem: 
Kube Proxy needed to be deployed for ACI to run as a part of upgrade from 3.9 to 3.10


Version-Release number of selected component (if applicable): 3.10

Issue:
The file playbooks/common/openshift-cluster/upgrades/v3_10/upgrade_control_plane.yml does not contains the role to run kube_proxy_and_dns for ACI.


Actual results:
No related kube-proxy-and-dns pod present/running.

Expected results:
kube-proxy-and-dns pod should be deployed and running 

Additional info:
The issue is basically seen because no role is there to deploy ACI as an SDN. The CNI task is absent as part of the upgrade process

Comment 1 Mike Cohen 2019-07-09 19:36:17 UTC
The fix regarding this has been merged - https://github.com/openshift/openshift-ansible/pull/11732

Comment 4 Johnny Liu 2019-08-13 04:11:15 UTC
Verify this bug with openshift-ansible-3.10.162-1.git.0.db3d25f.el7.noarch, and PASS.


Per discussion in https://bugzilla.redhat.com/show_bug.cgi?id=1708552, openshift QE have no ACI cluster, so in this testing, I would only verify the PR is merged and take effected. If anything wrong, pls correct me.


1. install a 3.9 cluster
2. set openshift_use_aci=true and aci_deployment_yaml_file='/opt/aci_deployment.yaml' in inventory file, upload your local aci_deployment.yaml to the 1st master in /opt/aci_deployment.yaml.
3. trigger 3.9 to 3.10 upgrade

In the log, I would see the follow PLAY.
PLAY [Run kube proxy, needed for ACI]
TASK [kube_proxy_and_dns : Ensure project exists]

So move this bug to VERIFIED.

Comment 6 errata-xmlrpc 2019-08-21 13:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2509


Note You need to log in before you can comment on or make changes to this bug.