Bug 172847 - su does not prompt for password on copy of root
su does not prompt for password on copy of root
Status: CLOSED DUPLICATE of bug 172846
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 10:32 EST by Bob Findlay
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 10:40:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Findlay 2005-11-10 10:32:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
we have a 2nd "root" account called "system" which has the same uid/gid as root.  a normal user can su to system without giving a password

Version-Release number of selected component (if applicable):
coreutils-5.2.1-48.1

How reproducible:
Always

Steps to Reproduce:
1.vipw    duplicate the root entry.  rename the 2nd on system
2.do the same in the shadow password
3.log in as a normal user
4. su - system

  

Actual Results:  
and no prompt for a password is given - you just become system

Expected Results:  should prompt for system password`

Additional info:
Comment 1 Tim Waugh 2005-11-10 10:40:06 EST

*** This bug has been marked as a duplicate of 172846 ***

Note You need to log in before you can comment on or make changes to this bug.