Bug 172854 - up2date crashes when there are corrupted (?) files in /var/spool/up2date
up2date crashes when there are corrupted (?) files in /var/spool/up2date
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 11:10 EST by Michael Stella
Modified: 2012-06-20 09:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:19:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Stella 2005-11-10 11:10:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
When trying to up2date I got:

	Fetching Obsoletes list for channel: rhel-i386-as-4...

	Fetching rpm headers...
	*** glibc detected *** realloc(): invalid pointer: 0x0a17faec
***
	Aborted

The pointer address changes each time (0x0a17faec)...

In the /var/log/up2date I get :

	[Wed Nov  9 14:28:20 2005] up2date updating login info
	[Wed Nov  9 14:28:20 2005] up2date logging into up2date server
	[Wed Nov  9 14:28:24 2005] up2date successfully retrieved authentication token from up2date server
	[Wed Nov  9 14:28:24 2005] up2date availablePackageList from network
	[Wed Nov  9 14:28:24 2005] up2date Unable to import repomd support so repomd support will not be available

I mv'ed all the file's in /var/spool/up2date and tried updating again - and it worked as expected.


Version-Release number of selected component (if applicable):
up2date-4.4.50-4

How reproducible:
Didn't try

Steps to Reproduce:
1. Havent tried - but I assume if I mv the files back to /var/spool/up2date 
2.It may crash again. I still have the files.
3.
  

Additional info:
Comment 1 Red Hat Bugzilla 2007-04-11 20:22:01 EDT
User bnackash@redhat.com's account has been closed
Comment 3 Jiri Pallich 2012-06-20 09:19:53 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.