Bug 172858 - yumex does not support http_proxy for use behind firewalls
yumex does not support http_proxy for use behind firewalls
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 12:01 EST by Herb Lewis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-20 00:05:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herb Lewis 2005-11-10 12:01:30 EST
Description of problem:
yumex does not seem to use the http_proxy environment variable so it will
not work behind my firewall

Version-Release number of selected component (if applicable):
yumex-0.42-9.0.fc4

How reproducible:
always

Steps to Reproduce:
1. start yumex behind a firewall that requires http_proxy
2. fails in initializing repositories
3.
  
Actual results:
fails initializing repositories

Expected results:
successful

Additional info:
Comment 1 Tim Lauridsen 2005-11-10 15:24:34 EST
I now there is some problems with proxys, it look like the proxy settings in
yum.conf dont work from yumex, i dont no why.
I cant test it because dont have access to a system behind a proxy firewall.

I have descripted a work around here:

http://linux.rasmil.dk/cms/modules/news/article.php?storyid=19

Until i find a good solution.
Comment 2 Tim Lauridsen 2005-11-20 00:05:54 EST
I have added a proxy feature to the current CVS release, it will be included in
the next public release.

Note You need to log in before you can comment on or make changes to this bug.