Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: When the upgrade activities script finishes and exit successfully, the gluster-blockd daemon running in the background may still not killed, so this will be a problem when the gluster-block service try to start: ERROR: gluster-blockd is already running... Version-Release number of selected component (if applicable): gluster-block-0.2.1-33.el7rhgs.x86_64 How reproducible: Always Steps to Reproduce: 1. Install latest OCS3.11.4 bits with LMR 2. 3. Actual results: I see that the install fails since gluster-blockd is in inactive state. Expected results: gluster-blockd should be in active state and install should not fail. Additional info:
PR: https://github.com/gluster/gluster-block/pull/246
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2019:3256