Bug 1728673 - Cannot see the "trusted.glusterfs.mdata" xattr for directory on a new brick after rebalance
Summary: Cannot see the "trusted.glusterfs.mdata" xattr for directory on a new brick a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: RHGS 3.5.0
Assignee: Kotresh HR
QA Contact: Sayalee
URL:
Whiteboard:
Depends On:
Blocks: 1696809 1734026 1752413 1752429
TreeView+ depends on / blocked
 
Reported: 2019-07-10 12:06 UTC by Sayalee
Modified: 2019-10-30 12:22 UTC (History)
10 users (show)

Fixed In Version: glusterfs-6.0-14
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1734026 (view as bug list)
Environment:
Last Closed: 2019-10-30 12:22:15 UTC
Target Upstream Version:
khiremat: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3249 0 None None None 2019-10-30 12:22:51 UTC

Description Sayalee 2019-07-10 12:06:54 UTC
Description of problem:
The "trusted.glusterfs.mdata" xattr was present on a dir on brick1 when it was created, but when added new brick (brick2) to the volume, and did rebalance as well, the xattr was not present on the dir on new brick(brick2).

Version-Release number of selected component (if applicable):
6.0.7

How reproducible:
Always

Steps to Reproduce:
1.Create a 1 brick distributed volume.
2.Mount the volume on a client node using fuse.
3.Create a dir on client node
#mkdir dir1
4.Check all the internal xattrs for the dir1 on the back-end using:
#getfattr -de hex -m . /bricks/brick1/dir1
5.Add a new brick to the volume.

Actual results:


Expected results:


Additional info:

Comment 29 errata-xmlrpc 2019-10-30 12:22:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.