Bug 172878 - rpm -V errors are broken with respect to Conflicts:
rpm -V errors are broken with respect to Conflicts:
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-11-10 14:45 EST by Bill Nottingham
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-13 21:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
[PATCH] display -Va dependency failures as Requires: or Conflicts: (#172878). (3.01 KB, patch)
2005-11-13 21:50 EST, Jeff Johnson
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2005-11-10 14:45:22 EST
[root@nostromo i386]# rpm -q --conflicts bar
[root@nostromo i386]# rpm -q --requires bar
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
[root@nostromo i386]# rpm -q ook bar
[root@nostromo i386]# rpm -V bar
Unsatisfied dependencies for bar-0.10-0.testing.1.i386: ook

Surely that should say something like:

Unsatisfied dependencies for bar-0.10-0.testing.1.i386: bar conflicts with ook

Version-Release number of selected component (if applicable):

[root@nostromo i386]# rpm -q rpm
Comment 1 Jeff Johnson 2005-11-12 20:52:27 EST
The information regarding whether it's a Requires: or a Conflicts:
is in lib/verify.c:443

     /* XXX FIXME: should probably supply the "[R|C] " type prefix */

I. e. R and C indicate whether it is a Requires: or Conflicts: failure.

The problem is conforming with ageless user expectations and API's (a similar
problem exists returning arch info through rpm-python) . The behavior
in rpm is same as always, and increasingly useless and broken.

E.g. yopu expectation seesm to indicate that packages "conflicts" and "with" have missing
dependencies while the package "bar" is self conflicting
Comment 2 Jeff Johnson 2005-11-13 21:49:08 EST
Perhaps this output is more to your liking:
Unsatisfied dependencies for rpm-devel-4.4.3-0.46.i386:
        Requires: libtool(/usr/lib/libbeecrypt.la)
        Requires: libtool(/usr/lib/libexpat.la)
        Requires: libtool(/usr/lib/libneon.la)
        Requires: libtool(/usr/lib/librpmdb.la)
        Requires: libtool(/usr/lib/librpmio.la)
        Requires: libtool(/usr/lib/libsqlite3.la)

Unsatisfied dependencies for apr-util-devel-0.9.7-4.i386:
        Requires: libtool(/usr/lib/libapr-0.la)
        Requires: libtool(/usr/lib/libexpat.la)

Fixed in CVS, will be in rpm-4.4.3-0.48 when built.
Comment 3 Jeff Johnson 2005-11-13 21:50:50 EST
Created attachment 121003 [details]
[PATCH] display -Va dependency failures as Requires: or Conflicts: (#172878).

display -Va dependency failures as Requires: or Conflicts: (#172878).

Note You need to log in before you can comment on or make changes to this bug.