Bug 172881 - mysql fails regression tests when building as root
mysql fails regression tests when building as root
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 15:41 EST by Robert Scheck
Modified: 2013-07-02 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 21:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-11-10 15:41:34 EST
Description of problem:
While rebuilding latest mysql package, I get the following error message:

[...]
rpl_innodb                     [ pass ]
rpl_insert_id                  [ pass ]
rpl_insert_ignore              [ pass ]
rpl_insert_select              [ pass ]
rpl_loaddata                   [ pass ]
rpl_loaddata_rule_m            [ pass ]
rpl_loaddata_rule_s            [ pass ]
rpl_loaddatalocal              [ pass ]
rpl_log                        [ pass ]
rpl_log_pos                    [ pass ]
rpl_many_optimize              [ pass ]
rpl_master_pos_wait            [ pass ]
rpl_max_relay_size             [ pass ]
rpl_misc_functions             [ pass ]
rpl_multi_delete               [ pass ]
rpl_multi_delete2              [ pass ]
rpl_multi_query                [ pass ]
rpl_multi_update               [ pass ]
rpl_multi_update2              [ pass ]
rpl_multi_update3              [ pass ]
rpl_mystery22                  [ pass ]
rpl_openssl                    [ skipped ]
rpl_optimize                   [ pass ]
rpl_ps                         [ pass ]
rpl_redirect                   [ pass ]
rpl_relayrotate                [ disabled ]  Unstable test case, bug#12429
rpl_relayspace                 [ pass ]
rpl_replicate_do               [ pass ]
rpl_reset_slave                [ pass ]
rpl_rewrite_db                 [ pass ]
rpl_rotate_logs                [ fail ]

Errors are (from /usr/src/redhat/BUILD/mysql-5.0.15/mysql-test/var/log/
mysqltest-time) :
mysqltest: At line 28: query 'start slave' failed with wrong errno 1201 instead 
of 1105...
(the last lines may be the most important ones)

Aborting: rpl_rotate_logs failed in default mode. To continue, re-run with '--
force'.

Ending Tests
Shutting-down MySQL daemon

Master shutdown finished
Slave shutdown finished
make: *** [test] Error 1

Version-Release number of selected component (if applicable):
mysql-5.0.15-2

How reproducible:
Everytime, try to rebuild.

Actual results:
No rebuilding.

Expected results:
Rebuilding.
Comment 1 Tom Lane 2005-11-10 17:33:58 EST
I built mysql 5.0 quite a few times in process of creating the package, and I
never saw that happen, so "everytime" is an overstatement.  Is there anything
unusual about your build environment?  Can you dig down and determine *why* the
message is appearing?  (Just looking at the test script, it seems to be an issue
of permissions on a test file, so relevant variables include what sort of
filesystem you are running the tests in and whether SELinux is enabled.)
Comment 2 Robert Scheck 2005-11-11 10:11:54 EST
Sorry Tom, for me it was everytime the case ;-)

I've running the ext3 filesystem and latest SELinux targeted policy enforced, 
but I didn't find any avc denied in syslogs.
Comment 3 Tom Lane 2005-11-11 12:54:30 EST
Hmph.  I tried running the build under SELinux enforcement mode, and didn't see
a failure ... and I am running ext3.  So it's quite unclear what's going on
here.  Can you think of any other reasons why your system would be different
from mine?
Comment 4 Tom Lane 2005-11-11 15:29:49 EST
I just had a thought: maybe the problem is not too little file permissions, but
too much.  Are you running the rpmbuild as root?  If so, does it work if you run
as non-root?
Comment 5 Robert Scheck 2005-11-11 16:53:40 EST
Yes, I'm running rpmbuild as root. And yes, it works for me as non-root user...
Comment 6 Tom Lane 2005-11-11 17:10:50 EST
Yup, I just reproduced the failure building as root.  Evidently the issue is
that the test script is expecting to see a file permissions failure when it
tries to read the config file, and it doesn't get one if the test is running as
root.

I'm inclined to classify this as "not a bug", or at least "wontfix".  We
generally don't build RPMs as root within Red Hat, and I have other packages
that fail to build as root for reasons much harder to work-around than this.
The upstream MySQL developers obviously don't run their regression tests as root
either ...
Comment 7 Tom Lane 2006-01-04 21:47:17 EST
Closing as WONTFIX per above comment; also, adjust summary line to describe the real issue.

Note You need to log in before you can comment on or make changes to this bug.