Bug 172885 - syslog-ng gets removed when sysklod is updated
syslog-ng gets removed when sysklod is updated
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syslog-ng (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jose Pedro Oliveira
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 15:54 EST by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: syslog-ng-1.6.9-2.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 19:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2005-11-10 15:54:37 EST
Description of problem:
syslog-ng is removed when the sysklogd RPM is updated

Steps to Reproduce:
1) system with sysklogd installed
2) install syslog-ng (in Fedora Extras)
3) build/install a sysklogd RPM with a bigger NVR
  
Actual results:
the syslog-ng package is removed from the system. 
The system loses its log daemon if the syslog-ng is the active one.

Expected results:
Be able to keep the syslog-ng package installed

Additional info:
I believe the the problem is caused by the Provides statement·
I had to include in syslog-ng specfile:

      "Provides: sysklogd = 1.4.1-99"

The above statement allows sysadmins to remove sysklogd and
leave only syslog-ng installed. The problem is that sysklogd
is required by the initscripts and the vixie-cron packages.

Example (FC4 system):
  $ rpm -e --test sysklogd
  error: Failed dependencies:
      sysklogd >= 1.3.31 is needed by (installed) \
          initscripts-8.11.1-1.i386
      sysklogd >= 1.3.33-6 is needed by (installed) \
          vixie-cron-4.1-36.FC4.i386

I believe a possible solution would involve using 
a neutral name (e.g.: syslog) that both daemon - sysklogd 
and syslog-ng - would provide.  This solution requires changing
the following Core packages:
   1) sysklogd    (provide statement)
   2) initscripts (require statement)
   3) vixie-cron  (require statement)
Comment 1 Jeremy Katz 2005-11-10 16:39:07 EST
This seems like a reasonable approach to me.  Bill, Jason -- any concerns?
Comment 2 Bill Nottingham 2005-11-10 17:14:54 EST
Sounds doable.
Comment 3 Jason Vas Dias 2005-11-10 17:33:58 EST
OK, I'll change sysklogd and vixie cron:
  sysklogd:   'Provides: syslog-1.4.1'
(but it will still also Provides:sysklogd-1.4.1 by default)
  vixie-cron: 'Requires: syslog >= 1.4.1'


Comment 4 Bill Nottingham 2005-11-10 17:52:50 EST
Realistically, I don't think the virtual provide needs versioned.

Probably:

sysklogd: Provides: syslog
vixie-cron: Requires: syslog
vixie-cron: Conflicts: sysklogd < 1.4.1

Comment 5 Jose Pedro Oliveira 2005-11-23 14:09:55 EST
Hi,

Now that test1 has been released would it be possible to have these changes
committed in the next few days?

Thanks in advance,
jpo

PS - syslog-ng 1.6.9 has been released today ([1])

References:

[1] [syslog-ng] syslog-ng 1.6.9 released
    https://lists.balabit.hu/pipermail/syslog-ng/2005-November/008195.html

[2] Syslog-ng roadmap (v2.0 and v2.2)
    http://www.balabit.com/products/syslog_ng/roadmap.bbq
Comment 6 Jose Pedro Oliveira 2005-12-15 13:57:23 EST
Jeremy, Bill, and Jason,

Would it be possible to have
    sysklogd providing syslog and
    initscripts and vixie-cron requiring syslog instead of sysklogd
before FC5Test2?

If I upload the patches, would it help?

Thanks in advance,
jpo 
Comment 7 Jason Vas Dias 2005-12-15 14:10:52 EST
OK, I'll submit a new version of sysklogd that provides: syslog today -
patches not required - thanks.
Comment 8 Jose Pedro Oliveira 2005-12-19 12:22:02 EST
Thanks for the updated packages:

  - sysklogd-1.4.1-34.src.rpm
  - initscripts-8.19-1.src.rpm
  - vixie-cron-4.1-42.FC5.src.rpm

/jpo
Comment 9 Jose Pedro Oliveira 2005-12-22 19:40:36 EST
Problem solved with above rawhide updates and syslog-ng-1.6.9-2 from Fedora
Extras development branch (syslog-ng-1.6.9-2.fc5 also started providing syslog).

Note You need to log in before you can comment on or make changes to this bug.