Bug 172886 - Poor signal handling in cluquorumd
Summary: Poor signal handling in cluquorumd
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 172895
TreeView+ depends on / blocked
 
Reported: 2005-11-10 21:00 UTC by Lon Hohberger
Modified: 2009-04-16 20:18 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0196
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 18:06:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes quorumd signal handling (1.94 KB, patch)
2005-11-10 21:06 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0196 normal SHIPPED_LIVE clumanager bug fix update 2006-03-27 05:00:00 UTC

Description Lon Hohberger 2005-11-10 21:00:09 UTC
Description of problem:

(a) SIGHUP isn't properly handled, and
(b) if two signals come in quickly, cluquorumd can deadlock because it call
syslog (and other unsafe things) in the signal handler for SIGHUP


Version-Release number of selected component (if applicable): 1.2.28


How reproducible: ?

Comment 1 Lon Hohberger 2005-11-10 21:06:24 UTC
Created attachment 120904 [details]
Fixes quorumd signal handling

Comment 3 Lon Hohberger 2005-11-11 20:59:05 UTC
A new *TEST* package build with several bugfixes (fixes bugzillas: 171637 172735
172893 172894 ) is available.  Gulm-bridge support has been disabled in this
release to prevent having to install with the "--nodeps" option:

http://people.redhat.com/lhh/clumanager-1.2.28.6-0.1nogfs.i386.rpm
http://people.redhat.com/lhh/clumanager-1.2.28.6-0.1nogfs.x86_64.rpm
http://people.redhat.com/lhh/clumanager-1.2.28.6-0.1nogfs.src.rpm

Let us know if this works for you.

Comment 4 Lon Hohberger 2005-12-14 21:22:06 UTC
QA

This is a pre-emptive strike against a potential problem,
and needs no testing.  Verify that the cluster still operates under
normal constraints.

Comment 5 Lon Hohberger 2005-12-14 21:34:27 UTC
Actually scratch that; writing a test case.

Comment 6 Lon Hohberger 2005-12-14 21:53:01 UTC
1.  Set cluquorumd to debug log level.  Send cluquorumd SIGHUP
signals very quickly by running this for a few seconds (presss ^C to
stop it):

    while [ 0 ]; do killall -HUP cluquorumd; done

2.  Run clustat.  It should hang. 
3.  On 1.2.30, this behavior should not exist.

Comment 9 Red Hat Bugzilla 2006-03-27 18:06:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0196.html



Note You need to log in before you can comment on or make changes to this bug.