Bug 1728894 - dnf repolist should be very fast
Summary: dnf repolist should be very fast
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 31
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1713055 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-10 21:37 UTC by Robbie Harwood
Modified: 2019-12-20 03:00 UTC (History)
10 users (show)

Fixed In Version: dnf-4.2.15-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-20 02:59:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Robbie Harwood 2019-07-10 21:37:27 UTC
Hi, I think `dnf repolist` should be instantaneous - it's just concerned with what repositories are and aren't configured on the system as far as I can tell.  However, it very much isn't:

[root@localhost ~]# time dnf repolist
Last metadata expiration check: 0:07:55 ago on Wed 10 Jul 2019 09:22:36 PM UTC.
repo id                                    repo name                                               status
*fedora                                    Fedora 30 - x86_64                                      56,582
*fedora-debuginfo                          Fedora 30 - x86_64 - Debug                              33,072
*fedora-modular                            Fedora Modular 30 - x86_64                                 135
*updates                                   Fedora 30 - x86_64 - Updates                             9,689
*updates-debuginfo                         Fedora 30 - x86_64 - Updates - Debug                     8,272
*updates-modular                           Fedora Modular 30 - x86_64 - Updates                       140
*updates-testing                           Fedora 30 - x86_64 - Test Updates                        7,904
*updates-testing-debuginfo                 Fedora 30 - x86_64 - Test Updates Debug                  5,307

real	0m15.613s
user	0m5.407s
sys	0m0.917s
[root@localhost ~]# 

(And this is on a fast x86_64 system - it gets even worse when it's not.)

Thanks!

Comment 1 Daniel Mach 2019-07-15 11:22:43 UTC
This is caused by printing the last column 'status'.
DNF downloads repodata, loads it in memory and prints package counts.

Comment 2 Jaroslav Mracek 2019-07-25 14:34:06 UTC
I create a patch that redesign repolist command - https://github.com/rpm-software-management/dnf/pull/1423.

Comment 3 Ben Cotton 2019-08-13 17:10:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 4 Ben Cotton 2019-08-13 18:55:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 5 Jaroslav Mracek 2019-10-19 15:31:07 UTC
*** Bug 1713055 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-11-11 09:43:20 UTC
FEDORA-2019-7cafbe66ba has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 7 Fedora Update System 2019-11-11 09:43:53 UTC
FEDORA-2019-94393775ec has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 8 Fedora Update System 2019-11-12 03:07:43 UTC
dnf-4.2.15-1.fc30, dnf-plugins-core-4.0.11-1.fc30, dnf-plugins-extras-4.0.8-1.fc30, libdnf-0.37.2-2.fc30, librepo-1.11.0-1.fc30, microdnf-3.0.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 9 Fedora Update System 2019-11-13 04:56:11 UTC
dnf-4.2.15-1.fc31, dnf-plugins-core-4.0.11-1.fc31, dnf-plugins-extras-4.0.8-1.fc31, libdnf-0.37.2-2.fc31, librepo-1.11.0-1.fc31, microdnf-3.0.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 10 Fedora Update System 2019-11-14 06:46:59 UTC
FEDORA-2019-7cafbe66ba has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 11 Fedora Update System 2019-11-14 06:50:46 UTC
FEDORA-2019-94393775ec has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 12 Fedora Update System 2019-11-15 03:45:08 UTC
dnf-4.2.15-3.fc30, dnf-plugins-core-4.0.11-1.fc30, dnf-plugins-extras-4.0.8-1.fc30, libdnf-0.37.2-2.fc30, librepo-1.11.0-1.fc30, microdnf-3.0.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 13 Fedora Update System 2019-11-15 04:38:40 UTC
dnf-4.2.15-2.fc31, dnf-plugins-core-4.0.11-1.fc31, dnf-plugins-extras-4.0.8-1.fc31, libdnf-0.37.2-2.fc31, librepo-1.11.0-1.fc31, microdnf-3.0.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 14 Fedora Update System 2019-11-19 01:35:12 UTC
dnf-4.2.15-2.fc31, dnf-plugins-core-4.0.11-1.fc31, dnf-plugins-extras-4.0.8-1.fc31, libdnf-0.37.2-2.fc31, librepo-1.11.0-1.fc31, microdnf-3.0.2-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-12-02 19:10:33 UTC
dnf-4.2.15-3.fc30, dnf-plugins-core-4.0.11-1.fc30, dnf-plugins-extras-4.0.8-1.fc30, libdnf-0.37.2-2.fc30, librepo-1.11.0-1.fc30, microdnf-3.0.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.