Bug 172891 - RFE: dogtail support in anaconda
RFE: dogtail support in anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: 169147 145814 F8Target
  Show dependency treegraph
 
Reported: 2005-11-10 16:17 EST by James Laska
Modified: 2013-09-02 02:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 12:20:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Information of Dogtail+Anaconda working together. (598.74 KB, application/x-gzip)
2007-04-13 13:08 EDT, Alexander Todorov
no flags Details

  None (edit)
Description James Laska 2005-11-10 16:17:15 EST
The idea of using dogtail to provide automated GUI testing of anaconda is very
appealing.  However, I believe there may be some python bindings (specifically
at-spi) needed in the installer environment for this to work.  I would like to
use this bug to track and discuss dogtail support in anaconda.

Thoughts/comments/concerns?
Comment 1 Jeremy Katz 2005-11-10 17:13:48 EST
This definitely seems like something which could be very worthwhile.  It should
be possible to get the set of what's needed and add them to an updates.img to
begin with.  Chris's support for updates= will help there too :)
Comment 2 Zack Cerza 2005-11-10 17:26:44 EST
The crucial first question that needs to be answered is "to what extent is
Anaconda accessible?". If the answer is not "None", then we should be able to
get something working. To investigate this it'd help to be able to have a shell
inside Anaconda, or a shell outside it but with all the X auth junk set up.
Comment 3 Jeremy Katz 2005-11-10 17:34:14 EST
Switch to tty2, export DISPLAY:1 and you should be good to go for looking at
things.  As far as accessibility, my answer is a very qualified "maybe" :)

I'm all but certain there's probably work that needs doing but I'd think that
basic things are there as we do just use gtk...
Comment 4 Jeremy Katz 2005-11-10 18:47:58 EST
Okay, so as it stands now, the second stage is missing quite a bit of stuff. 
I've just taken a pass at adding some of that and am building now.  We'll see if
I can actually then import pyspi tomorrow
Comment 5 Jeremy Katz 2005-11-11 15:17:19 EST
Stuff added and it looks like it works.  We don't have pyspi or dogtail in the
image by default since they're not in core so I can't pull them in, but you can
definitely put them into an updates.img with your dogtail script to do stuff.

Also, right now you need to touch /etc/redhat-release to keep from confusing
dogtail.  Ed took down a note so that hopefully that won't have to be done :-)
Comment 6 Edward Rousseau 2005-11-11 16:00:48 EST
Looks like we need to add screenshot support via pygtk so we can capture
anaconda. This would be a big win for l10n anaconda testing. As far as compares
go at that state - we will have to address that. As in comment #5 - we need to
not bail if we can't detect rpms -- a config flag maybe? Just some ideas to hash
out next dogtail planning meeting.
Comment 7 Jeremy Katz 2005-11-11 16:14:54 EST
The compare side of things is really something that you're going to more want to
do as a post-processing type of thing, not while anaconda is running (I'd
think).  I'll try to whip up a quick patch for the screenshot functionality.

More brainstorming -- we're going to want to be able to kick off an install
saying that it should use dogtail and probably doing that _instead_ of
kickstart.  So passing all of the install method info via the command line and
then adding dogtail= to get a dogtail script to run.  

The scripts used for anaconda will probably want to upload any screenshots or
other results somewhere as well, probably analagous to what is done with KATE.
Comment 8 Chris Lumens 2007-03-14 16:44:27 EDT
What's the status here?  I see pyspi and dogtail in the tree now.  What still
needs to be done in anaconda?
Comment 9 Jeremy Katz 2007-03-23 14:35:39 EDT
Like I said, we want something like dogtail= to be able to pass a dogtail
script.  Or some way of easily doing so from a kickstart.  As it is, you can
probably _use_ dogtail, but it's not very integrated or easy to do
Comment 10 Alexander Todorov 2007-04-13 13:08:14 EDT
Created attachment 152559 [details]
Information of Dogtail+Anaconda working together.

I have this working already. The approach used is the same as discussed here.
I guess most of the work has been done over time and only a couple of files
were needed. This is 2 MB so probably they can be added to stage2.img by
default.
More details are in the attached file.
Comment 11 Chris Lumens 2008-01-23 12:20:16 EST
Committed to rawhide.  Thanks for the patches.  Let's use new bugs for tracking
any issues that crop up from this.

Note You need to log in before you can comment on or make changes to this bug.