Bug 1729068 - Installed Blogilo but it doesn't start at all.
Summary: Installed Blogilo but it doesn't start at all.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blogilo
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 10:47 UTC by inori.hs
Modified: 2019-07-13 01:06 UTC (History)
4 users (show)

Fixed In Version: blogilo-17.08.3-14.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-13 01:06:53 UTC
Type: Bug


Attachments (Terms of Use)

Description inori.hs 2019-07-11 10:47:57 UTC
Description of problem:

Installed latest blogilo package into Fedora 30 but it doesnā€™t start at all.

It seems that InsertTableWidget::typeOfLength member function is lost from class KPIMTextEdit for some reason. But as far as checking inserttablewidget.cpp in kf5-kpimtextedit-19.04.2-1.fc30.src.rpm, the member function seems to be defined.

Version-Release number of selected component (if applicable):
Application : blogilo-17.08.3-13.fc30.x86_64.rpm


How reproducible:
100% reproducible.

Steps to Reproduce:
1. Install blogilo.
2. Exec blogilo.

Actual results:
Error log :
/usr/bin/blogilo: symbol lookup error: /lib64/libcomposereditorwebengineprivate.so.5: undefined symbol: _ZNK12KPIMTextEdit17InsertTableWidget12typeOfLengthEv

Expected results:
Blogilo starts.

Additional info:

Comment 1 Kevin Kofler 2019-07-11 11:02:59 UTC
I guess the function is no longer exported from the library? I'll have to extend my export fixing patch.

It is quite sad that kpimtextedit upstream keeps going out of their way to break Blogilo for no good reason.

Comment 2 Kevin Kofler 2019-07-11 11:05:54 UTC
Actually, the patch was simply omitted from the latest kf5-kpimtextedit update! Rex, this is just plain unacceptable. Please at least ping me if you are disabling my patch.

Comment 3 Fedora Update System 2019-07-11 12:11:36 UTC
FEDORA-2019-94e6716848 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94e6716848

Comment 4 inori.hs 2019-07-11 12:26:37 UTC
Updated to kf5-kpimtextedit-19.04.2-2.fc30, but blogilo still does'nt work.
It seems that yet another functions/classes are lost.

New error log:
/usr/bin/blogilo: symbol lookup error: /usr/bin/blogilo: undefined symbol: _ZN9PimCommon19CustomToolsWidgetNgC1EP17KActionCollectionP7QWidget

Comment 5 Kevin Kofler 2019-07-11 12:37:01 UTC
So this is not in kpimtextedit, but in pimcommon:
https://cgit.kde.org/pimcommon.git/commit/?id=96b0e478f30eaa15c6fcf04a20b18e8efa91429a

I need to adapt Blogilo to this change, in addition to the kf5-kpimtextedit patch which is also needed and will also be pushed.

Comment 6 Kevin Kofler 2019-07-11 12:42:37 UTC
Actually, since the change is this:
-    explicit CustomToolsWidgetNg(KActionCollection *ac, QWidget *parent = nullptr);
+    explicit CustomToolsWidgetNg(QWidget *parent = nullptr);
and Blogilo actually passes this:
    mCustomToolsWidget = new PimCommon::CustomToolsWidgetNg(nullptr);
a recompile will be enough. (It'll just pass parent=nullptr explicitly instead of the intended ac=nullptr, but that is not going to change anything.)

Comment 7 Kevin Kofler 2019-07-11 13:24:19 UTC
I added blogilo-17.08.3-14.fc30 to:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-94e6716848

Please try that build and give feedback in Bodhi (i.e., at the above link).

Comment 8 inori.hs 2019-07-11 14:01:00 UTC
Thanks to your modification and rebuilding Kevin, blogilo can be opened now.

But unfortunately I found that blogilo doen't work well.
1. The 'visual editor' is not editable(no reaction to mouse clicks and keyboard inputs).
2. After opening a recent post, at first 'Visual Editor' displays contents of the post, but once switching to 'HTML Editor' tab, the contents is empty. And returned to 'Visual Editor' tab, previously displayed contents are all cleared and nothing's displayed.

These bugs seems to have been reported since some years ago.

The cause of these bugs is probably due to the fact that the library specifications used by blogilo have changed. It there anyone who can fix blogilo's these bugs still now?

Comment 9 Kevin Kofler 2019-07-11 14:18:34 UTC
I'll have a look into unbreaking Blogilo further, but not now.

The blanking can be worked around by using the clipboard to save text. In some cases, Undo also helped (but not always). But this is a major annoyance.

The visual editor, I'm not sure that it is even expected to work, ever since they moved away from the ancient KHTML. QtWebEngine doesn't do visual editing.

Comment 10 Fedora Update System 2019-07-12 02:15:45 UTC
blogilo-17.08.3-14.fc30, kf5-kpimtextedit-19.04.2-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94e6716848

Comment 11 Fedora Update System 2019-07-13 01:06:53 UTC
blogilo-17.08.3-14.fc30, kf5-kpimtextedit-19.04.2-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.