Bug 1729099 - User field separator uses '$$' within ipaSELinuxUserMapOrder.
Summary: User field separator uses '$$' within ipaSELinuxUserMapOrder.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.1
Assignee: Thomas Woerner
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 12:09 UTC by anuja
Modified: 2019-11-05 20:53 UTC (History)
5 users (show)

Fixed In Version: ipa-server-4.8.0-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:53:20 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3348 None None None 2019-11-05 20:53:33 UTC

Description anuja 2019-07-11 12:09:44 UTC
Description of problem:
User field separator uses '$$' within ipaSELinuxUserMapOrder.
Previously it was '$' only

Version-Release number of selected component (if applicable):
ipa-server-4.8.0-1.module+el8.1.0+3577+202f0a51.x86_64

Steps to Reproduce:
1. ipa config-show | grep "SELinux user map order: guest_u:s0$xguest_u:s0$user_u:s0$staff_u:s0-s0:c0.c1023$sysadm_u:s0-s0:c0.c1023$unconfined_u:s0-s0:c0.c1023"


Actual results:

# ipa config-show 
  Maximum username length: 32
  Maximum hostname length: 64
  Home directory base: /home
  Default shell: /bin/sh
  Default users group: ipausers
  Default e-mail domain: bak2.test
  Search time limit: 2
  Search size limit: 100
  User search fields: uid,givenname,sn,telephonenumber,ou,title
  Group search fields: cn,description
  Enable migration mode: FALSE
  Certificate Subject base: O=BAK2.TEST
  Password Expiration Notification (days): 4
  Password plugin features: AllowNThash, KDC:Disable Last Success
  SELinux user map order: guest_u:s0$$xguest_u:s0$$user_u:s0$$staff_u:s0-s0:c0.c1023$$sysadm_u:s0-s0:c0.c1023$$unconfined_u:s0-s0:c0.c1023
  Default SELinux user: unconfined_u:s0-s0:c0.c1023
  Default PAC types: MS-PAC, nfs:NONE
  IPA masters: kvm-01-guest05.bak2.test
  IPA master capable of PKINIT: kvm-01-guest05.bak2.test
  IPA CA servers: kvm-01-guest05.bak2.test
  IPA CA renewal master: kvm-01-guest05.bak2.test
  IPA DNS servers: kvm-01-guest05.bak2.test
[root@kvm-01-guest05 ~]# 

Expected results:
There should not be extra '$' in separator field

Comment 1 anuja 2019-07-11 12:20:08 UTC
downstream test suite
bash:ipa-default
Failed test : General Server Configuration

Comment 2 Florence Blanc-Renaud 2019-07-11 13:02:09 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/8005

Comment 3 Florence Blanc-Renaud 2019-07-11 13:04:21 UTC
Upstream PR in progress https://github.com/freeipa/freeipa/pull/3372

Comment 4 Alexander Bokovoy 2019-07-15 11:43:25 UTC
master:

* ac1ea0ec6710f40adffc3f04b39422f3043c6554 Fix `test_webui.test_selinuxusermap`

Comment 5 Alexander Bokovoy 2019-07-16 07:12:37 UTC
ipa-4-8:

* 96af5394c210e637a5ab81d6925be3b0a429fc08 Fix `test_webui.test_selinuxusermap`

Comment 6 Alexander Bokovoy 2019-07-16 07:14:15 UTC
Will be fixed in an idm:DL1 module build that includes ipa-server-4.8.0-3.el8

Comment 8 anuja 2019-07-22 09:08:05 UTC
Verified using :
ipa-server-4.8.0-4.module+el8.1.0+3696+eb4a1e69.x86_64

[root@apollo ~]#  ipa config-show 
  Maximum username length: 32
  Maximum hostname length: 64
  Home directory base: /home
  Default shell: /bin/sh
  Default users group: ipausers
  Default e-mail domain: bak2.test
  Search time limit: 2
  Search size limit: 100
  User search fields: uid,givenname,sn,telephonenumber,ou,title
  Group search fields: cn,description
  Enable migration mode: FALSE
  Certificate Subject base: O=BAK2.TEST
  Password Expiration Notification (days): 4
  Password plugin features: AllowNThash, KDC:Disable Last Success
  SELinux user map order: guest_u:s0$xguest_u:s0$user_u:s0$staff_u:s0-s0:c0.c1023$sysadm_u:s0-s0:c0.c1023$unconfined_u:s0-s0:c0.c1023
  Default SELinux user: unconfined_u:s0-s0:c0.c1023
  Default PAC types: MS-PAC, nfs:NONE
  IPA masters: apollo.bak2.test
  IPA CA servers: apollo.bak2.test
  IPA CA renewal master: apollo.bak2.test
  IPA DNS servers: apollo.bak2.test

There is no extra '$' in SELinux user map order
Based on this marking bz as verified.

Comment 10 errata-xmlrpc 2019-11-05 20:53:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3348


Note You need to log in before you can comment on or make changes to this bug.