Bug 1729101 - On Fedora Rawhide, the ghc module does not have the default stream set.
Summary: On Fedora Rawhide, the ghc module does not have the default stream set.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: ghc
Version: unspecified
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 12:16 UTC by Lukas Ruzicka
Modified: 2020-01-08 10:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-08 10:03:33 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 12:16:21 UTC
Description of problem:
On Fedora Rawhide, the ghc does not have the default stream is not set. DNF will not install the module using `dnf module install ghc`, because it does not know which stream it should take. Defining a default should be considered a good practice. Because of that, I think this is a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list ghc

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Jens Petersen 2019-09-25 12:20:17 UTC
Sure thanks for the report - I suppose this started since F31 branched from Rawhide.

(<grumble/> I wish the module system handling this better, it is kind of tedious doing PRs for each branch...)

Comment 2 Jens Petersen 2019-09-25 13:18:52 UTC
Oops ignore previous comment - I mistook dates and forgot I already fixed this at the time.

Comment 3 Jens Petersen 2019-09-25 13:36:37 UTC
But then I misread... I see now you are asking about default stream not default profile...

That is kind of a "feature" - the default "stream" is really the non-module ghc!


Note You need to log in before you can comment on or make changes to this bug.