RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1729115 - udica tracebacks after receiving data from podman inspect <CONTAINER-ID>
Summary: udica tracebacks after receiving data from podman inspect <CONTAINER-ID>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: udica
Version: 8.1
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 8.1
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 12:36 UTC by Milos Malik
Modified: 2020-11-14 07:44 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:56:46 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3377 0 None None None 2019-11-05 20:56:48 UTC

Description Milos Malik 2019-07-11 12:36:36 UTC
Description of problem:

Version-Release number of selected component (if applicable):
RHEL-8.1
udica-0.1.5-2.el8.noarch
podman-manpages-1.4.2-1.module+el8.1.0+3423+f0eda5e0.noarch
podman-1.4.2-1.module+el8.1.0+3423+f0eda5e0.x86_64

How reproducible:
 * always

Steps to Reproduce:
1. get a RHEL-8.1 machine (targeted policy is active)
2. git clone https://src.fedoraproject.org/rpms/udica.git
3. cd udica/tests/sanity
4. ./runtest.sh
5. look for tracebacks / fails

Actual results:
Traceback (most recent call last):
  File "/usr/bin/udica", line 11, in <module>
    load_entry_point('udica==0.1.5', 'console_scripts', 'udica')()
  File "/usr/lib/python3.6/site-packages/udica/__main__.py", line 107, in main
    create_policy(opts, container_caps, container_mounts, container_ports)
  File "/usr/lib/python3.6/site-packages/udica/policy.py", line 125, in create_policy
    if not item['source'].find("/"):
KeyError: 'source'

Expected results:
 * no tarceback

Comment 5 errata-xmlrpc 2019-11-05 20:56:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3377


Note You need to log in before you can comment on or make changes to this bug.