Bug 1729119 - New template is not pointing to the correct clusterserviceclass
Summary: New template is not pointing to the correct clusterserviceclass
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jesus M. Rodriguez
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 12:40 UTC by Aditya Deshpande
Modified: 2019-08-28 14:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-28 14:50:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Aditya Deshpande 2019-07-11 12:40:43 UTC
Description of problem:
By mistake if template is deleted. Associated clusterserviceclass is not pointing to the correct template as template is not available. So, new template created is not pointing to the clusterserviceclass correctly and not available on the service catalog.

I tried with the workaround in such way keeping scenario such that there is no related clusterserviclass and template in OCP environment.
In this scenario if I create a new template then new clusterserviceclass is automatically generated pointing to the correct template.

But this scenario seems to be not feasible since we cannot manage the servicebinding of the currently running serviceinstance.

can we create the template for specific uid for already present clusterserviceclass? 



Version-Release number of selected component (if applicable):
OCP 3.9


Actual results:
The newly created template is not pointing to the correct clusterserviceclass because of that deployment of the template cannot be done from service catalog.

Comment 2 Joe Lanford 2019-07-29 20:35:05 UTC
It seems like the Template Service Broker is working as expected. There is no way for it to know if the newly created templates are equivalent to the old template.

Comment 3 Jesus M. Rodriguez 2019-08-28 14:50:10 UTC
If a template is removed there is currently no way or reassociating it back. This is not a bug.


Note You need to log in before you can comment on or make changes to this bug.