Bug 1729124 - On Fedora Rawhide, the jmc module does not have the default stream set.
Summary: On Fedora Rawhide, the jmc module does not have the default stream set.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: jmc
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jie Kang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 12:43 UTC by Lukas Ruzicka
Modified: 2019-07-23 13:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 13:52:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 12:43:18 UTC
Description of problem:
On Fedora Rawhide, the jmc module does not have the default stream set. Although DNF will install the module using `dnf module install jmc`, defining a default should be considered a good practice. Because of that, I think this is a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list jmc

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Jie Kang 2019-07-11 13:55:35 UTC
The master branch of fedora-module-defaults does contain a jmc.yaml file defining the 'latest' stream as default [1]. Does this not affect rawhide? Otherwise, I only see release specific branches, like f30, f29, etc. If you could point me at the right location, I'd be happy to fix this.


https://pagure.io/releng/fedora-module-defaults/blob/master/f/jmc.yaml

Comment 2 Lukas Ruzicka 2019-07-16 09:49:15 UTC
Thank you for the info. I am not sure where to check, but I will try to poke around.

Comment 3 Lukas Ruzicka 2019-07-16 11:10:16 UTC
So, I have found out, that the yaml file has to look a little different, something like this:

	
document: modulemd-defaults
	
version: 1
	
data:
	
    module: jmc

    stream: latest
	
    modified: 201901291640
	
    profiles:
	
        latest: [default]

Comment 4 Jie Kang 2019-07-16 12:42:26 UTC
Thanks for the info. I've opened a PR [1] to update this.

[1]
https://pagure.io/releng/fedora-module-defaults/pull-request/135#

Comment 5 Jie Kang 2019-07-16 13:08:30 UTC
I forgot about the interaction with default module streams and non-modular rpms.

The JMC module contains a conflicting version of javamail which would override the non-modular javamail rpm. This makes it unsuitable for having a default stream.

Comment 6 Lukas Ruzicka 2019-07-23 13:52:39 UTC
Thanks for clarification. I am closing the bug.


Note You need to log in before you can comment on or make changes to this bug.