Bug 1729133 - On Fedora Rawhide, the mysql module does not have the default stream and profile set.
Summary: On Fedora Rawhide, the mysql module does not have the default stream and prof...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: mysql
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 12:56 UTC by Lukas Ruzicka
Modified: 2019-09-10 10:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-10 10:43:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 12:56:23 UTC
Description of problem:
On Fedora Rawhide, the mysql module does not have the default stream and profile set. Therefore, DNF will not install the module using `dnf module install mysql`. It will only enable it. Since modules should be able to install using the aforementioned command, I consider this a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list mysql

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Lukas Ruzicka 2019-07-23 14:10:40 UTC
Default streams are no longer required, but default profiles are. Please set the default profile for every stream. This module also does not have a corresponding yaml file in https://pagure.io/releng/fedora-module-defaults/. 
Please, fix. Thank you.

Comment 3 Michal Schorm 2019-08-27 16:42:37 UTC
PR merged

Comment 4 Lukas Ruzicka 2019-08-29 08:12:54 UTC
Thank you very much, I verify that the yaml exists, so I am expecting that this will be solved in the next compose.

Comment 5 Michal Schorm 2019-09-10 10:43:49 UTC
I tested the current Rawhide

# dnf module list mysql
| Name             Stream               Profiles                             Summary                                                  
| mysql            5.7                  client, default, server [d]          MySQL Module                                             
| mysql            8.0                  devel, client, server [d]            MySQL Module                                             


# dnf module install mysql:8.0
| Installing module profiles:
|  mysql/server
| Enabling module streams:
|  mysql                          8.0



Looks fixed to me.


Note You need to log in before you can comment on or make changes to this bug.