Bug 1729138 - On Fedora Rawhide, the perl module does not have the default stream set.
Summary: On Fedora Rawhide, the perl module does not have the default stream set.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: perl
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 13:03 UTC by Lukas Ruzicka
Modified: 2019-07-11 13:23 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-11 13:23:20 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 13:03:57 UTC
Description of problem:
On Fedora Rawhide, the perl module does not have the default stream set. Because there are multiple streams available for this module, DNF will not install using `dnf module install perl`. It will report an error instead. Since modules should be able to install using the aforementioned command, I consider this a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list perl

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Petr Pisar 2019-07-11 13:23:20 UTC
perl module cannot have a default stream because Perl is also packaged in the classical non-modular repository and Fedora does not allow modules to override non-modular packages.


Note You need to log in before you can comment on or make changes to this bug.