Bug 172914 - install boot option "nousbstorage" disables USB
install boot option "nousbstorage" disables USB
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 03:20 EST by Sogor, Laszlo
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 01:01:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Candidate #3 - replace __setup with __module_param_call (765 bytes, patch)
2005-12-20 17:03 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Sogor, Laszlo 2005-11-11 03:20:53 EST
Description of problem:
When start Fedora Core 3 installer and specifies the "nousbstorage" option, 
the full USB support is disabled, therefore FC3 cannot be installed to a machine
which has only USB keyboard.

The problem exist with FC4 as well.


Version-Release number of selected component (if applicable):
anaconda-10.1.0.2-1.x86_64


How reproducible:
always


Steps to Reproduce:
1. Get a machine with only USB keyboard
2. Start FC3 install with 'linux text nousbstorage'
3. Wait for anaconda to come up and load several drivers
  
Actual results:
The USB devices are disabled after the kernel boots

Expected results:
Only the USB storage devices should be disabled, not the whole USB support

Additional info:
Not only the 'nousbstorage' keyword disables all USB devices, but - I think - 
all ketwords begin with 'nousb'. I tried 'nousbasd' and 'nousbasdasd', both
disabled the USB support.

When used a PS/2 keyboard and specified any boot option begins with 'nousb', I
experienced the following:
From the shell the installer opens:
# grep usb /proc/devices
# grep usb /proc/filesystems
#

The /tmp/anaconda.log contains the following lines:
...
failed to mount device usbfs: No such file or directory
waiting for usb to become stable...
...

I compiled the USB HCI drivers (ehci, ohci and uhci) to the kernel, it has the
same problem: the full USB seems to be disabled.

I added a new boot option to anaconda 'skipusbstorage' which does exactly 
the same as 'nousbstorage' in loader2/loader.c:parseCmdLineFlags():
sets the LOADER_FLAGS_NOUSBSTORAGE flag.
After rebuilding anaconda packages and the distro and start the install with
'linux text skipusbstorage', everything is O.K., i.e. it has USB support and the
USB storage module is not loaded.

It seems that something before anaconda does a bad string match and disables the
full USB support for all boot options begins with 'nousb'. 

Maybe the kernel.
Comment 1 Jeremy Katz 2005-11-11 23:23:32 EST
Does this still occur with later releases?  I'm not reproducing it in a quick
test here.
Comment 2 Sogor, Laszlo 2005-11-14 04:07:29 EST
I checked it with FC3 (dvd) and FC4 (cd) downloaded from an official Fedora
mirror (wftp.tu-chemnitz.de).

Did not check with the development tree.

Used 2 machines to test. Always can reproduce on both configurations
(USB keyboard and mouse):
- HP xw8200 workstation
- SUN Fire x4200

Comment 3 Jeremy Katz 2005-11-17 02:43:56 EST
This is due to the kernel interpreting it and it still seems to happen with
current (2.6.15-rc)
Comment 4 Pete Zaitcev 2005-12-20 13:46:31 EST
Adding Jeremy to keep him informed, though this is confirmed as kernel
bug/feature/whatever.
Comment 5 Pete Zaitcev 2005-12-20 17:03:30 EST
Created attachment 122468 [details]
Candidate #3 - replace __setup with __module_param_call

This seems like that the only sensible solution. I definitely do not want to
touch the implementation of __setup(), with all places doing __setup("foo=").
Comment 6 Dave Jones 2006-01-16 17:22:11 EST
This is a mass-update to all currently open Fedora Core 3 kernel bugs.

Fedora Core 3 support has transitioned to the Fedora Legacy project.
Due to the limited resources of this project, typically only
updates for new security issues are released.

As this bug isn't security related, it has been migrated to a
Fedora Core 4 bug.  Please upgrade to this newer release, and
test if this bug is still present there.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

Thank you.
Comment 7 Jeremy Katz 2006-01-16 19:02:47 EST
Still occurs when I tried a few weeks ago
Comment 8 Pete Zaitcev 2006-01-16 20:22:58 EST
The fix is in Linus's tree (2.6.15-git11), so I am waiting for Dave to import it
in due time.
Comment 9 Dave Jones 2006-01-17 00:57:54 EST
git11 was yesterdays build, so it should be there now for rawhide.

FC4 will pick it up when it gets a .16 rebase.


Note You need to log in before you can comment on or make changes to this bug.