Bug 1729142 - "lpamdin -p <queue> -o cupsSNMPSupplies:false" doesn't work
Summary: "lpamdin -p <queue> -o cupsSNMPSupplies:false" doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 13:09 UTC by Zdenek Dohnal
Modified: 2019-09-06 05:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-06 05:48:50 UTC


Attachments (Terms of Use)

Description Zdenek Dohnal 2019-07-11 13:09:34 UTC
This bug was initially created as a copy of Bug #1726383

I am copying this bug because: 



Description of problem:

  running

    lpadmin -p printq -o cupsSNMPSupplies=false

  and

    lpadmin -p printq -o cupsIPPSupplies=false    

  doesn't work

Version-Release number of selected component (if applicable):

  cups-2.2.6-21.el8.x86_64

How reproducible:

  100%

Steps to Reproduce:

  lpadmin -p printq -o cupsSNMPSupplies=false
  grep SNMP /etc/cups/ppd/printq.ppd

Actual results:

  grep should find "*cupsSNMPSupplies: False" in the PPD file

Expected results:

  The expected line isn't written to the PPD file

Additional info:

  The lpadmin command creates a new PPD file, but when it sends
  the CUPS-Add-Modify-Printer request to the CUPS server, it doesn't
  include the "ppd-name" attribute in the request, so the server
  never uses the new PPD.

  (At least I think that's what's going on)

  I'll do further investigation to determine the root cause, work on a patch,
  and then submit the patch upstream.

Comment 1 Zdenek Dohnal 2019-07-18 14:03:59 UTC
Upstream already has merged fix, links are in original ticket.

Comment 2 Ben Cotton 2019-08-13 16:47:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 3 Zdenek Dohnal 2019-09-06 05:48:50 UTC
Fixed in cups-2.2.12, which is now in F30+.


Note You need to log in before you can comment on or make changes to this bug.