Bug 1729150 - On Fedora Rawhide, the ruby module does not have the default stream set.
Summary: On Fedora Rawhide, the ruby module does not have the default stream set.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: ruby
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jun Aruga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 13:15 UTC by Lukas Ruzicka
Modified: 2019-09-04 12:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-16 16:22:05 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 13:15:59 UTC
Description of problem:
On Fedora Rawhide, the ruby module does not have the default stream set. Because there are multiple streams available for this module, DNF will not install using `dnf module install ruby`. It will report an error instead. Since modules should be able to install using the aforementioned command, I consider this a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list ruby

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Jun Aruga 2019-07-11 13:53:58 UTC
Sure, we need to add the default stream to ruby.yaml like scala.yaml.

https://docs.fedoraproject.org/en-US/modularity/making-modules/managing-defaults/
https://pagure.io/releng/fedora-module-defaults/blob/master/f/scala.yaml

Comment 2 Lukas Ruzicka 2019-07-16 09:40:50 UTC
Thanks, please do.

Comment 4 Jun Aruga 2019-07-16 14:20:12 UTC
Lukas Ruzicka, your request to set the default stream might be declined by fesco until Fedora module technology will solve some problems.
See https://pagure.io/fesco/issue/2178#comment-582472

Comment 5 Jun Aruga 2019-07-16 16:22:05 UTC
Hi Lukas, I would close this ticket.

As I told you for blow commment, I do not want to install Ruby module by "dnf install ruby".
https://pagure.io/fesco/issue/2178#comment-582517

Comment 6 Vít Ondruch 2019-09-04 12:14:35 UTC
*** Bug 1748895 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.