Bug 1729158 - On Fedora Rawhide, the skychart module does not have the default stream and profile set.
Summary: On Fedora Rawhide, the skychart module does not have the default stream and p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: skychart
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mattia Verga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 13:21 UTC by Lukas Ruzicka
Modified: 2020-05-29 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-29 16:32:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 13:21:37 UTC
Description of problem:
On Fedora Rawhide, the skychart module does not have the default stream and profile set. Therefore, DNF will not install the module using `dnf module install skychart`. It will only enable it. Since modules should be able to install using the aforementioned command, I consider this a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list skychart

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Mattia Verga 2019-07-12 06:40:53 UTC
I created the Skychart module to get in touch with modules, but I've found it's too much work and useless effort (skychart is always developed with rolling releases except few stable releases as checkpoints).

I have to find out how to delete the entire module.

Comment 2 Lukas Ruzicka 2019-07-23 13:58:53 UTC
Thank you for the information. Let me know, when you will be removing the module.

Comment 3 Lukas Ruzicka 2019-07-31 14:16:27 UTC
The skychart modules still exists in the current compose. Will you be deleting it?

Comment 4 Mattia Verga 2019-08-04 12:36:32 UTC
(In reply to Lukas Ruzicka from comment #3)
> The skychart modules still exists in the current compose. Will you be
> deleting it?

Yes, is there any documentation on how to do that?
I've just came back from two weeks holidays and slowing catching up with work...

Comment 5 Mattia Verga 2019-08-17 08:01:22 UTC
I've opened a releng issue to get Skychart module removed:
https://pagure.io/releng/issue/8640

Comment 6 Lukas Ruzicka 2019-08-19 14:51:16 UTC
Thank you. I will monitor that. :)

Comment 7 Lukas Ruzicka 2019-08-29 08:15:17 UTC
I can confirm, that the module no longer exists in Fedora.
Thank you very much.


Note You need to log in before you can comment on or make changes to this bug.