Bug 1729172 - On Fedora Rawhide, the postgresql module does not have the default stream and profile set.
Summary: On Fedora Rawhide, the postgresql module does not have the default stream and...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Petr Kubat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 13:38 UTC by Lukas Ruzicka
Modified: 2019-07-23 13:56 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 13:56:52 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-07-11 13:38:02 UTC
Description of problem:
On Fedora Rawhide, the postgresql module does not have the default stream and profile set. Therefore, DNF will not install the module using `dnf module install postgresql`. It will only enable it. Since modules should be able to install using the aforementioned command, I consider this a bug.

How reproducible:
Always

Steps to reproduce:
1. dnf module list postgresql

Expected results:
Modules should have the defaults set.

Additional info:
If you did not set the defaults on purpose, please share the reason and confirm that explicitely.

Comment 1 Petr Kubat 2019-07-12 06:33:53 UTC
Hi, thanks for the report.

We do not have default streams set since we still have non-modularized rpm content available in regular repositories. Afaik there is still the issue with buildroot not being able to use default streams for modules, so until that is possible we will have to rely on regular repositories for the content.

Setting default profiles for the streams seems like a good idea though. Will look into it.

Comment 3 Pavel Raiskup 2019-07-12 07:36:55 UTC
(In reply to Petr Kubat from comment #1)
> We do not have default streams set since we still have non-modularized rpm
> content available in regular repositories. Afaik there is still the issue
> with buildroot not being able to use default streams for modules, so until
> that is possible we will have to rely on regular repositories for the
> content.

Well, my original goal was to not bother users by modularity if they don't
want to be bothered (strict opt-in).  That is -> they should have the good
old Fedora work-flow WRT PostgreSQL:
-> one default version of postgresql for particular Fedora version, and
-> hit postgresql-setup --upgrade after fedora distro upgrade
If they want to, they can easily move to modular postgresql (even if that
doesn't really mean different postgresql version).

I'm not saying you can not change this ... :-), just saying that even
if the modular build-requires worked fine - I wouldn't do that.

Comment 4 Lukas Ruzicka 2019-07-12 08:16:16 UTC
That seems like a plausible reason for the defaults not to be set. 
From my perspective, I am not able to recognize if you do it on purpose, or if you just forgot to set it. Now, after clarification, I can whitelist the module and not bother you with that anymore, until you realize you want something else.
Is that ok?

Comment 5 Lukas Ruzicka 2019-07-16 09:53:22 UTC
The change has been merged, so I take this as fixed and I will verify in a compose.

Comment 6 Lukas Ruzicka 2019-07-23 13:56:10 UTC
Verified.


Note You need to log in before you can comment on or make changes to this bug.