Bug 1729207 - ipa-healthcheck: consider naming the log file healthcheck.log instead of healthcheck.log-$(date +%Y%m%d)
Summary: ipa-healthcheck: consider naming the log file healthcheck.log instead of heal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa-healthcheck
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.1
Assignee: Rob Crittenden
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 14:52 UTC by François Cami
Modified: 2020-11-14 06:25 UTC (History)
4 users (show)

Fixed In Version: ipa-healthcheck-0.3-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:53:20 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3348 0 None None None 2019-11-05 20:53:33 UTC

Description François Cami 2019-07-11 14:52:53 UTC
Description of problem:
Currently (*) ipa-healthcheck logs into:
/var/log/ipa/healthcheck/healthcheck.log-$(date +%Y%m%d)
e.g.
/var/log/ipa/healthcheck/healthcheck.log-20190711

(*) after the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1729188

Please consider using healthcheck.log for the default (latest) log instead and a logrotate tool.

Version-Release number of selected component (if applicable):
ipa-healthcheck-0.2-3.module+el8.1.0+3389+a3c612fa.noarch


How reproducible:
Always


Steps to Reproduce:
1. systemctl daemon-reload
2. systemctl enable ipa-healthcheck.timer
3. systemctl start ipa-healthcheck.timer
3. wait 24h

Actual results:
Log file in /var/log/ipa/healthcheck contains the date in its name

Expected results:
Log file is unversioned so that analysis tools can find the latest log easily.

Additional info:
https://github.com/freeipa/freeipa-healthcheck/issues/35

Comment 2 Sudhir Menon 2019-09-12 10:38:50 UTC
Fix is seen. Verified on RHEL8.1

[root@master healthcheck]# cat /etc/redhat-release 
Red Hat Enterprise Linux release 8.1 Beta (Ootpa)

[root@master healthcheck]# rpm -q ipa-healthcheck
ipa-healthcheck-0.3-4.module+el8.1.0+4098+f286395e.noarch
ipa-server-4.8.0-10.module+el8.1.0+4098+f286395e.x86_64

[root@master healthcheck]# rpm -ql ipa-healthcheck
/etc/ipahealthcheck
/etc/ipahealthcheck/ipahealthcheck.conf
/etc/logrotate.d/ipahealthcheck
/usr/bin/ipa-healthcheck
/usr/share/doc/ipa-healthcheck/README.md
/usr/libexec/ipa/ipa-healthcheck.sh

[root@master ~]# systemctl daemon-reload
[root@master ~]# systemctl enable ipa-healthcheck.timer
Created symlink /etc/systemd/system/multi-user.target.wants/ipa-healthcheck.timer → /usr/lib/systemd/system/ipa-healthcheck.timer.
[root@master ~]# systemctl start ipa-healthcheck.timer


[root@master logrotate.d]# cat /etc/logrotate.d/ipahealthcheck 
/var/log/ipa/healthcheck/healthcheck.log {
    create
    daily
    dateext
    missingok
    rotate 30
}

[root@master healthcheck]# cat /usr/libexec/ipa/ipa-healthcheck.sh 
#!/bin/sh
LOGDIR=/var/log/ipa/healthcheck
/usr/bin/ipa-healthcheck --output-file $LOGDIR/healthcheck.log


[root@master healthcheck]# pwd
/var/log/ipa/healthcheck
[root@master healthcheck]# ls -l
total 52
-rw-r--r--. 1 root root 50324 Sep 12 16:02 healthcheck.log

Comment 4 errata-xmlrpc 2019-11-05 20:53:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3348


Note You need to log in before you can comment on or make changes to this bug.