Bug 172922 - Evolution crashes if dbus-daemon is not present
Evolution crashes if dbus-daemon is not present
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 07:02 EST by Luis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-2.10.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 16:24:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis 2005-11-11 07:02:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If a user starts evolution and there is not a dbus-daemon dbus-launcher it just crashes at startup.
For example it happens if you are in a session and make 

su - otheruser
evolution

Or if you start a graphical session that does not launch dbus-daemon for example xinit + twm

Version-Release number of selected component (if applicable):
evolution-2.2.3-2.fc4

How reproducible:
Always

Steps to Reproduce:
1.Start a session that does not launch dbus-daemon or kill user's dbus-daemon
2.
3.
  

Actual Results:  Evolution crashes.

Expected Results:  In this case evolution should be able to start itself the daemon, shouldn't it?

Additional info:

Error messaging report as it crashes.

It gives the following error report

######################################################
es menu class init
adding hook target 'source'
Failed to connect to the D-BUS daemon: Unable to determine the address of the message bus
2684: arguments to dbus_connection_get_data() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 4478.
This is normally a bug in some application using the D-BUS library.
2684: arguments to dbus_connection_set_data() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 4442.
This is normally a bug in some application using the D-BUS library.

** ERROR **: Not enough memory to set up DBusConnection for use with GLib
aborting...
Comment 1 Dave Malcolm 2005-11-11 16:32:42 EST
Thanks for this bug report.

As a workaround, you may want to follow these instructions:
http://mail.gnome.org/archives/evolution-list/2005-June/msg00197.html
Comment 3 Matthew Barnes 2006-05-15 12:09:44 EDT
This sounds very similar to upstream bug #314598.
(http://bugzilla.gnome.org/show_bug.cgi?id=314598)
Comment 4 Matthew Barnes 2006-05-15 12:22:23 EDT
And also to upstream bug #274329, which proposes a fix.
(http://bugzilla.gnome.org/show_bug.cgi?id=274329)
Comment 5 Matthew Barnes 2007-01-01 13:35:24 EST
Is this problem still present in Fedora Core 6?
Comment 6 Luis 2007-07-11 11:18:49 EDT
It seems that the problem is solved in fedora 7
Comment 7 Matthew Barnes 2007-07-11 16:24:05 EDT
Cool, thanks for the update.  Closing this.

Note You need to log in before you can comment on or make changes to this bug.