Bug 1729224 - Document procedure to upgrade environments that were deployed with Web UI [NEEDINFO]
Summary: Document procedure to upgrade environments that were deployed with Web UI
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jose Luis Franco
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 15:57 UTC by Andreas Karis
Modified: 2019-11-25 13:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-25 13:52:13 UTC
Target Upstream Version:
dcadzow: needinfo? (mbracho)
dcadzow: needinfo? (jcoufal)
dcadzow: needinfo? (mbarnett)


Attachments (Terms of Use)

Description Andreas Karis 2019-07-11 15:57:58 UTC
Description of problem:
Hi, we need to document the procedure to upgrade environments that were deployed with Web UI

Thanks,

Andreas

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Ideally, we should also tell customers in the doc that the preferred way to deploy is the CLI, that the Web UI is limited, and that once they dpeloyed with the Web UI (if they do so) they should download and save their plan and environment files as a backup.

Comment 5 Carlos Camacho 2019-08-12 12:45:28 UTC
Hi,

In order to decouple the update/upgrade from the UI, we need to retrieve the actual
deployment command used.

This should be provided either by DF:DFG or UI:DFG
after we have the reference about the deployment command used the update/upgrade
should follow the standard procedure.

Comment 7 Jan Buchta 2019-11-20 18:11:01 UTC
Since this is happening during an upgrade from EOL version, this needs to be solved in collaboration between upgrades and the portion of DF that still has the knowledge.

Comment 8 Jose Luis Franco 2019-11-25 13:52:13 UTC
Hello Andreas,

I see the related case is closed and the problem got solved, as this is a EOL version I'll close the bug as won't fix. Feel free to re-open it if you see the issue again.


Note You need to log in before you can comment on or make changes to this bug.