Bug 1729265 - Dialog fields not showing on the service order page when the field is tag control
Summary: Dialog fields not showing on the service order page when the field is tag con...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.11.0
Assignee: Martin Hradil
QA Contact: Niyaz Akhtar Ansari
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 17:31 UTC by Niyaz Akhtar Ansari
Modified: 2019-12-12 13:36 UTC (History)
10 users (show)

Fixed In Version: 5.11.0.19
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-12 13:36:46 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
dialog with tag element (4.32 KB, text/plain)
2019-07-11 17:31 UTC, Niyaz Akhtar Ansari
no flags Details
Screenshot showing actual result. (77.76 KB, image/png)
2019-07-11 17:32 UTC, Niyaz Akhtar Ansari
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4199 None None None 2019-12-12 13:36:58 UTC

Description Niyaz Akhtar Ansari 2019-07-11 17:31:19 UTC
Created attachment 1589593 [details]
dialog with tag element

Description of problem:


Version-Release number of selected component (if applicable):
Version 5.10.7.0.20190709151852_68f0bf9


How reproducible:
100%

Steps to Reproduce:
1. Import the dialog 
2. Add dialog in service
3. Go to order page

Actual results:
Dialog fields are missing on the service order page when the field tag control added in the dialog

Expected results:


Additional info:
Demo: https://url.corp.redhat.com/demo-tag-control

Comment 2 Niyaz Akhtar Ansari 2019-07-11 17:32:41 UTC
Created attachment 1589594 [details]
Screenshot showing actual result.

Comment 4 Tina Fitzgerald 2019-07-12 14:00:48 UTC
Hi Niyaz,

I reviewed the video, and setup a reproducer. The tag control works properly when you select a category.
The tag control requires this selection.

Can you try that and let me know if it works properly for you?

Thanks,
Tina

Comment 5 Niyaz Akhtar Ansari 2019-07-15 08:07:12 UTC
Hi Tina,

Yes right, tag control works properly when we select a category.

The issue is when we are not selecting the category of tag control it doesn't display the fields(dropdown, textbox.) on the service order page

Comment 10 Martin Hradil 2019-08-01 13:29:04 UTC
Validation of tag controls: https://github.com/ManageIQ/ui-components/pull/407
Showing validation errors: https://github.com/ManageIQ/manageiq-ui-classic/pull/5922

Comment 11 Martin Hradil 2019-08-05 14:47:16 UTC
(simpler version of the "show validation errrors" PR: https://github.com/ManageIQ/manageiq-ui-classic/pull/5938)

Comment 12 CFME Bot 2019-08-07 11:17:59 UTC
New commit detected on ManageIQ/ui-components/master:

https://github.com/ManageIQ/ui-components/commit/0ef2acb87f28906112ed9b4f397e5174275bae34
commit 0ef2acb87f28906112ed9b4f397e5174275bae34
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Aug  1 09:14:25 2019 -0400
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Aug  1 09:14:25 2019 -0400

    Dialog editor - validate tag category

    this is set to "", not null when unset,
    and it's in options

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1729265

 src/dialog-editor/services/dialogValidationService.ts | 5 +-
 1 file changed, 3 insertions(+), 2 deletions(-)

Comment 13 CFME Bot 2019-08-07 22:38:38 UTC
New commit detected on ManageIQ/ui-components/ivanchuk:

https://github.com/ManageIQ/ui-components/commit/2974d1dde7b8640897b044c4c049589c97ad4043
commit 2974d1dde7b8640897b044c4c049589c97ad4043
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Wed Aug  7 07:16:10 2019 -0400
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed Aug  7 07:16:10 2019 -0400

    Merge pull request #407 from himdel/validate-tag-category

    Dialog editor - validate tag category

    (cherry picked from commit e172cbc3513660e23542bb0c1907a6621b973d00)

    https://bugzilla.redhat.com/show_bug.cgi?id=1729265

 src/dialog-editor/services/dialogValidationService.ts | 39 +-
 1 file changed, 28 insertions(+), 11 deletions(-)

Comment 15 Niyaz Akhtar Ansari 2019-08-19 09:07:08 UTC
Verified in Version 5.11.0.19.20190813184334_ed72c9f

Comment 17 errata-xmlrpc 2019-12-12 13:36:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4199


Note You need to log in before you can comment on or make changes to this bug.