Bug 172933 - gdm segfaults on boot
Summary: gdm segfaults on boot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-11-11 13:34 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-10 22:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (22.51 KB, text/plain)
2005-11-11 13:34 UTC, Nicolas Mailhot
no flags Details

Description Nicolas Mailhot 2005-11-11 13:34:54 UTC
Description of problem:

gdm segfaults when started

Version-Release number of selected component (if applicable):

[nim@rousalka ~]$ rpm -q gdm
gdm-2.6.0.8-16
[nim@rousalka ~]$ rpm -V gdm
........C   /usr/lib64/gtk-2.0/modules/libdwellmouselistener.so
........C   /usr/lib64/gtk-2.0/modules/libkeymouselistener.so

How reproducible:

Always

Steps to Reproduce:
1. Go into init level 5
  
Actual results:

Several failed gdm startup attempts

When looking in dmesg :

hald-probe-smbi[1959] trap stack segment rip:401147 rsp:7fffffe1cc60 error:0
gdm-binary[2216]: segfault at 0000000000000000 rip 00002aaaae82deab rsp
00007fffffb23940 error 4
gdm-binary[2272]: segfault at 0000000000000000 rip 00002aaaae82deab rsp
00007fffffb23820 error 4
gdm-binary[2328]: segfault at 0000000000000000 rip 00002aaaae82deab rsp
00007fffffb23820 error 4
gdm-binary[2384]: segfault at 0000000000000000 rip 00002aaaae82deab rsp
00007fffffb23820 error 4
gdm-binary[2440]: segfault at 0000000000000000 rip 00002aaaae82deab rsp
00007fffffb23820 error 4
gdm-binary[2496]: segfault at 0000000000000000 rip 00002aaaae82deab rsp
00007fffffb23820 error 4

Expected results:

Successful gdm load

Comment 1 Nicolas Mailhot 2005-11-11 13:34:54 UTC
Created attachment 120939 [details]
dmesg output

Comment 2 Ray Strode [halfline] 2005-11-11 15:26:03 UTC
Hi,

There was some fixes in the source for those files a while back by Steve Grubb.
 What if you upgrade to the latest rawhide?

Comment 3 Nicolas Mailhot 2005-11-11 15:50:08 UTC
This was the latest rawhide as of yesterday (minus openssl bits)

Now upgrading to today's rawhide

Comment 4 Ray Strode [halfline] 2005-11-11 16:14:14 UTC
Hi Nicolas,

Do you have some yum excludes lines in place?

The latest version of gdm is gdm-2.8.0.4-8.

gdm-2.6.0.8-16 hasn't been in rawhide since August.

Comment 5 Nicolas Mailhot 2005-11-11 16:50:53 UTC
Sorry I had downgraded to FC4 gdm today to check - it segfaults too.

After a full sync the segfault is still there

So the bug is in one of the other packages gdm uses - probably hal stuff given
the error messages :

hald-probe-smbi[1937] trap stack segment rip:401147 rsp:7fffff957bc0 error:0
gdm-binary[2193]: segfault at 0000000000000000 rip 00002aaaaeef4eab rsp
00007fffff8ee990 error 4
gdm-binary[2249]: segfault at 0000000000000000 rip 00002aaaaeef4eab rsp
00007fffff8ee870 error 4
gdm-binary[2305]: segfault at 0000000000000000 rip 00002aaaaeef4eab rsp
00007fffff8ee870 error 4
gdm-binary[2361]: segfault at 0000000000000000 rip 00002aaaaeef4eab rsp
00007fffff8ee870 error 4
gdm-binary[2417]: segfault at 0000000000000000 rip 00002aaaaeef4eab rsp
00007fffff8ee870 error 4
gdm-binary[2473]: segfault at 0000000000000000 rip 00002aaaaeef4eab rsp
00007fffff8ee870 error 4


Comment 6 Nicolas Mailhot 2005-11-11 18:06:39 UTC
$ rpm -q gdm
gdm-2.8.0.4-8


Comment 7 Nicolas Mailhot 2005-11-12 16:32:22 UTC
Just to be sure I forced a reinstall of all the rpms in my yum cache (checking
them with rpm -K before), and did a new full rawhide sync, and the problem is
still there

Comment 8 Nicolas Mailhot 2005-12-10 22:20:39 UTC
This one seems to have been fixed by one of the latest rawhide updates


Note You need to log in before you can comment on or make changes to this bug.