Bug 172937 - chkconfig will NOT modify nscd run state
chkconfig will NOT modify nscd run state
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 09:26 EST by Clay Campbell
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 15:44:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clay Campbell 2005-11-11 09:26:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
I noticed nscd was running on my FC4 firewall.  I still use FC3 for most server stuff.  nscd hung when I rebooted the machine this morning.  I ended up having to hard power off.

When the machine booted again, I went to chkconfig to see why nscd was even running, I didn't think it was needed.  nscd was set off for all run-levels, yet it started at boot time.  When trying to set it on for level 345 or level 3 it doesn't change to on.

Version-Release number of selected component (if applicable):
chkconfig-1.3.20

How reproducible:
Always

Steps to Reproduce:
1.  booted up to find nscd running ps -ef|grep nscd
2.  sudo /sbin/chkconfig --list |grep nscd  nothing shows
3.  sudo /sbin/chkconfig --level 3 nscd on
4.  sudo /sbin/chkconfig --list |grep nscd  level 3 still set to off
  

Actual Results:  run levels/states are not set for nscd

Tried other services, and got expected results from chkconfig --level

Expected Results:  the run level should change when chkconfig --level 3 nscd on is committed

Additional info:

It is also fishy that the machine hung up on nscd while shutting down.  Maybe if I was patient it would have stopped properly, but I needed to reboot this machine quickly.  I was very surprised nscd was running in the first place.
Comment 1 Clay Campbell 2005-11-11 09:31:44 EST
nscd (GNU libc) 2.3.5

and I did update using 

$>yum -y update 

on 11/10/2005 

nscd hung up during the shutdown of the first reboot since the yum update
after waiting a few minutes, I power-off shutdown the machine

everything booted up fine, but nscd started, regardless of the fact chkconfig
set nscd to level 1-5 off
Comment 2 Bill Nottingham 2005-11-11 13:10:32 EST
What does 'ls /etc/rc*.d/*nscd' say?
Comment 3 Clay Campbell 2005-11-11 14:13:12 EST
$> ls /etc/rc*.d/*nscd
/etc/rc0.d/K74nscd  /etc/rc2.d/K74nscd  /etc/rc4.d/K74nscd  /etc/rc5.d/K74nscd 
/etc/rc6.d/K74nscd
/etc/rc1.d/K74nscd  /etc/rc3.d/S-1nscd  /etc/rc4.d/S-1nscd  /etc/rc5.d/S-1nscd
Comment 4 Bill Nottingham 2005-11-11 14:29:10 EST
What version of glibc?
Comment 5 Clay Campbell 2005-11-11 14:55:57 EST
Sep 07 12:37:36 Updated: glibc-common.i386 2.3.5-10.3
Sep 07 12:37:50 Updated: glibc.i686 2.3.5-10.3
Sep 07 12:38:58 Updated: glibc-headers.i386 2.3.5-10.3
Sep 07 12:39:00 Updated: glibc-devel.i386 2.3.5-10.3
Comment 6 Bill Nottingham 2005-11-11 15:44:31 EST
Should be fixed with chkconfig-1.3.22-0.4, being pushed shortly. You may need to
run:

rm -f /etc/rc*.d/*nscd
chkconfig --add nscd

before it will be handled correctly.
Comment 7 Clay Campbell 2005-11-11 16:51:24 EST
Wordz!

Note You need to log in before you can comment on or make changes to this bug.