Bug 1729380 - hyperv-testdev device test via kvm-unit-tests failed
Summary: hyperv-testdev device test via kvm-unit-tests failed
Keywords:
Status: CLOSED DUPLICATE of bug 1668573
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: qemu-kvm
Version: 8.1
Hardware: x86_64
OS: Linux
high
unspecified
Target Milestone: rc
: ---
Assignee: Vitaly Kuznetsov
QA Contact: liunana
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 07:04 UTC by liunana
Modified: 2020-01-07 06:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-05 16:38:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description liunana 2019-07-12 07:04:20 UTC
Description of problem:
hyperv-testdev device test via kvm-unit-tests failed


Version-Release number of selected component (if applicable):
host:
    kernel-4.18.0-114.el8.x86_64
    qemu-kvm-4.0.0-5.module+el8.1.0+3622+5812d9bf.x86_64
    seabios-bin-1.11.1-4.module+el8.1.0+3531+2918145b.noarch


How reproducible:
6/6


Steps to Reproduce:
1. clone the kvm-unit-test and do configuration
   # git clone git://git.kernel.org/pub/scm/virt/kvm/kvm-unit-tests.git
   # cd kvm-unit-tests
   # ./configure
   # make
2. Execute the test only related with Hyper-V Enlightenment
   [kvm-unit-tests]# ./x86/run ./x86/hyper_synic.flat -cpu SandyBridge-IBRS,hv_stimer,hv_synic,hv_time,hv_relaxed,hv_vpindex,hv_ipi,hv_spinlocks=0xfff,hv_vapic,hv_tlbflush,hv_reset,hv_crash -device hyperv-testdev
  
  failed with error:
   qemu: could not load kernel './x86/hyper_synic.flat': No such file or directory

3. Or run all tests
   [kvm-unit-tests]# ./run_tests.sh

   failed with message:
     FAIL hyperv_synic (terminated on SIGABRT)
     FAIL hyperv_connections (terminated on SIGABRT)
     FAIL hyperv_stimer (terminated on SIGABRT)
     PASS hyperv_clock 
     PASS intel_iommu (11 tests)

Actual results:
Test failed


Expected results:
Test can pass without error


Additional info:

Comment 2 Rick Barry 2019-07-12 14:37:28 UTC
Setting ITR=8.1.0 since Priority=High, but please review and change, if you don't think this needs to be addressed in RHEL-AV 8.1.0.

Comment 3 Vitaly Kuznetsov 2019-09-05 16:38:15 UTC
(In reply to liunana from comment #0)

> 2. Execute the test only related with Hyper-V Enlightenment
>    [kvm-unit-tests]# ./x86/run ./x86/hyper_synic.flat -cpu
> SandyBridge-IBRS,hv_stimer,hv_synic,hv_time,hv_relaxed,hv_vpindex,hv_ipi,
> hv_spinlocks=0xfff,hv_vapic,hv_tlbflush,hv_reset,hv_crash -device
> hyperv-testdev
>   
>   failed with error:
>    qemu: could not load kernel './x86/hyper_synic.flat': No such file or
> directory

You have a typo: it should by 'hyperv_synic.flat', not 'hyper_synic.flat'.

> 
> 3. Or run all tests
>    [kvm-unit-tests]# ./run_tests.sh
> 
>    failed with message:
>      FAIL hyperv_synic (terminated on SIGABRT)
>      FAIL hyperv_connections (terminated on SIGABRT)
>      FAIL hyperv_stimer (terminated on SIGABRT)
>      PASS hyperv_clock 
>      PASS intel_iommu (11 tests)

This is known as https://bugzilla.redhat.com/show_bug.cgi?id=1668573

*** This bug has been marked as a duplicate of bug 1668573 ***

Comment 4 liunana 2020-01-07 06:18:09 UTC
Since it is CANTFIX bug mark it as "qe_test_coverage -".


Note You need to log in before you can comment on or make changes to this bug.